[SOLVED] System unbootable - grub error: disk lvmid not found (when pluging in new disk)


New Member
Feb 3, 2023
On my NUC I installed last version 7.4-4 on a SDD M2 1Tb without any problem. Then I plugged an additional internal disk SSD 1To containing 1 partition eFAT filled under windows 11.
But no more able to boot. I got the following error:
Welcome to GRUB!
error: disk `lvmid/........./............` not found.
grub rescue>
I tried the following fix (last section) https://pve.proxmox.com/wiki/Recover_From_Grub_Failure but unsuccessful.

If I remove the additional disk boot is ok.

Other point, the additional disk looks correct. I tried to plug it into proxmox using usb and the access was ok!

Any idea?
I solved the issue... I inverted the use of the 2 disks and no more problem.
It's more a workaround than a solution I guess...


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!