Switch, Openvswitch, PfSense and Trunk ports

Hi,

I'm tring the following setup: PfSense on Proxmox with trunk to a managed switch.

Here's a diagram, everything works but not the PC up above: it gets a vlan1 IP but should be on vlan10 (Port10 on the switch). The VM attached to vmbr2 rightly gets the IP from PfSense.
I'd like to understand where the vlans get broken. Could it be the physical NICs aren't vlan aware? Or is it something in the confs?

networking.png

Here is Proxmox (OpenVSwitch) configutration:
Code:
auto lo
iface lo inet loopback

auto eno4
iface eno4 inet manual
    ovs_type OVSPort
    ovs_bridge vmbr4

auto eno3
iface eno3 inet manual
    ovs_type OVSPort
    ovs_bridge vmbr3
    ovs_options vlan_mode=native-tagged trunks=20,40 tag=20

auto eno2
iface eno2 inet manual
    ovs_type OVSPort
    ovs_bridge vmbr2
    ovs_options vlan_mode=native-tagged trunks=1,10,100 tag=1
   
auto eno1
iface eno1 inet manual
    ovs_type OVSPort
    ovs_bridge vmbr1

auto vlan2_1
iface vlan2_1 inet static
    address 10.0.0.22/24
    gateway 10.0.0.1
    ovs_type OVSIntPort
    ovs_bridge vmbr2
    ovs_options tag=1
#LAN

auto vlan2_10
iface vlan2_10 inet manual
    ovs_type OVSIntPort
    ovs_bridge vmbr2
    ovs_options tag=10
#VM subnet

auto vlan2_100
iface vlan2_100 inet manual
    ovs_type OVSIntPort
    ovs_bridge vmbr2
    ovs_options tag=100
#Management

auto vlan3_20
iface vlan3_20 inet static
    address 10.0.20.11/24
    ovs_type OVSIntPort
    ovs_bridge vmbr3
    ovs_options tag=20
#Cluster

auto vlan4_30
iface vlan4_30 inet static
    address 10.0.30.11/24
    ovs_type OVSIntPort
    ovs_bridge vmbr4
    ovs_options tag=30
#CephClusterNetwork

auto vlan1
iface vlan1 inet manual
    ovs_type OVSIntPort
    ovs_bridge vmbr1
#WAN

auto vlan3_40
iface vlan3_40 inet static
    address 10.0.40.11/24
    ovs_type OVSIntPort
    ovs_bridge vmbr3
    ovs_options tag=40
#CephPublicNetwork

auto vmbr2
iface vmbr2 inet manual
    ovs_type OVSBridge
    ovs_ports eno2 vlan2_1 vlan2_10 vlan2_100

auto vmbr3
iface vmbr3 inet manual
    ovs_type OVSBridge
    ovs_ports eno3 vlan3_20 vlan3_40

auto vmbr4
iface vmbr4 inet manual
    ovs_type OVSBridge
    ovs_ports eno4 vlan4_30

auto vmbr1
iface vmbr1 inet manual
    ovs_type OVSBridge
    ovs_ports eno1 vlan1

and here is the switch conf:

Code:
[systeminfo]
hostname  Intellinet560917
system location Rack
[clock]
clock set 19:52:21 2 25 2022
[vlan]
vlan 1,10,20,30,40,100
vlan 1
name LAN
exit
vlan 10
name VirtualMachines
exit
vlan 20
name Cluster
exit
vlan 30
name Storage
exit
vlan 40
name StorageCluster
exit
vlan 100
name Management
exit
[time-range]
[user]
Some user config
[enable_password]
[sysmanage]
  interface vlan 1
ip address ip-mode static
ip address 10.0.0.120 255.255.255.0 gateway 10.0.0.1
ip address dns major 8.8.8.8
exit
[loopback-detection]
[lacp]
[systemlog]
logging console 6
logging buffered 16384 6
logging monitor 6
no logging trap
[acl]
[qos]
[monitor]
[igmp]
[port]
interface management
exit
interface gigabitethernet 1
no shutdown
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan add 1,10,100
exit
interface gigabitethernet 2
no shutdown
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan add 1,10,100
exit
interface gigabitethernet 3
no shutdown
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan add 1,10,100
exit
interface gigabitethernet 4
no shutdown
exit
interface gigabitethernet 5
no shutdown
switchport mode trunk
switchport trunk native vlan 20
switchport trunk allowed vlan add 20,40
exit
interface gigabitethernet 6
no shutdown
switchport mode trunk
switchport trunk native vlan 20
switchport trunk allowed vlan add 20,40
exit
interface gigabitethernet 7
no shutdown
switchport mode trunk
switchport trunk native vlan 20
switchport trunk allowed vlan add 20,40
exit
interface gigabitethernet 8
no shutdown
switchport mode access
switchport access vlan 30
exit
interface gigabitethernet 9
no shutdown
switchport mode access
switchport access vlan 30
exit
interface gigabitethernet 10
no shutdown
switchport mode access
switchport access vlan 30
exit
interface gigabitethernet 11
no shutdown
exit
interface gigabitethernet 12
no shutdown
exit
interface gigabitethernet 13
no shutdown
exit
interface gigabitethernet 14
no shutdown
exit
interface gigabitethernet 15
no shutdown
exit
interface gigabitethernet 16
no shutdown
exit
interface gigabitethernet 17
no shutdown
exit
interface gigabitethernet 18
no shutdown
exit
interface gigabitethernet 19
no shutdown
exit
interface gigabitethernet 20
no shutdown
switchport mode access
switchport access vlan 10
exit
interface gigabitethernet 21
no shutdown
switchport mode access
switchport access vlan 20
exit
interface gigabitethernet 22
no shutdown
switchport mode access
switchport access vlan 30
exit
interface gigabitethernet 23
no shutdown
switchport mode access
switchport access vlan 40
exit
interface gigabitethernet 24
no shutdown
switchport mode access
switchport access vlan 100
exit
interface gigabitethernet 25
no shutdown
exit
interface gigabitethernet 26
no shutdown
exit
[snmp]
snmp-server enable
[mstp]
[dot1x]
[sntp]
sntp master enable
sntp server 144.76.76.104 0.0.0.0 0.0.0.0 5 30 2 1
clock timezone Amsterdam 1 0
[erps]
[ipsg]
[dhcp]
ip dhcp-relay
ip helper-address 10.0.0.1
ip helper-address 10.0.10.1
ip helper-address 10.0.100.1
ip helper-address 10.0.20.1
ip helper-address 10.0.30.1
ip helper-address 10.0.40.1
ip helper-address 10.0.0.100
[dos]
[rmon]
[telnetssh]
no enable service telnet-server
[arp]
[aaa]
[tacacs]
[radius]
[lldp]
[mac]
[errdisable]
[eoam]
[udld]
[mvr]
[vstack]
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!