Stucked during update 6 to 7 (8)

sdfsdfsfgdsgthgth

New Member
Nov 16, 2023
8
0
1
Hello, I tried to update my 6.4.15 version to 7 and after to 8.
Here is where I´m stucked at 58% of progress:
root@emailer:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
bsdmainutils python-backports.functools-lru-cache python-bcrypt python-bs4 python-ceph-argparse python-cherrypy3
python-dnspython python-formencode python-jwt python-logutils python-mako python-markupsafe python-paste
python-pastedeploy python-pecan python-rgw python-simplegeneric python-simplejson python-singledispatch python-soupsieve
python-tempita python-waitress python-webob python-webtest python-werkzeug python3-asn1crypto
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
bind9-dnsutils bind9-libs bsdextrautils fonts-urw-base35 gcc-10-base libapt-pkg6.0 libcbor0 libcrypt1 libctf-nobfd0
libctf0 libdns-export1110 libdns1110 libevent-2.1-7 libffi7 libfido2-1 libgcc-s1 libglusterd0 libhogweed6 libipset13
libisc-export1105 libisc1105 libjson-c5 libmaxminddb0 libmd0 libnettle8 libnsl2 libopeniscsiusr libperl4-corelibs-perl
libprocps8 libreadline8 libuv1 libxxhash0 logsave mailcap manpages-dev media-types ncal pci.ids runit-helper uuid-runtime
The following packages have been kept back:
ceph ceph-base ceph-common ceph-fuse ceph-mds ceph-mgr ceph-mgr-modules-core ceph-mon ceph-osd chafa curl gdisk
ghostscript groff-base iproute2 iptables libanyevent-perl libapt-pkg-perl libasound2 libasound2-data libauthen-pam-perl
libc-bin libc-dev-bin libc6 libc6-dev libcairo2 libcephfs2 libchafa0 libclone-perl libcommon-sense-perl
libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcrypt-ssleay-perl libcupsfilters1
libcurl3-gnutls libcurl4 libfilesys-df-perl libflac8 libfreetype6 libgfortran5 libgoogle-perftools4 libgs9 libgs9-common
libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libheif1 libhtml-parser-perl libhttp-message-perl libiptc0 libjemalloc2
libjson-xs-perl liblcms2-2 liblinux-inotify2-perl liblocale-gettext-perl liblua5.3-0 libmagickcore-6.q16-6
libmagickwand-6.q16-6 libnet-dbus-perl libnet-ssleay-perl libnspr4 libnss-systemd libopenjp2-7 libopus0 libpam-systemd
libpixman-1-0 libpng16-16 libpulse0 libpython2-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib
libpython3-stdlib librados2 libradosstriper1 librbd1 librdkafka1 librgw2 librrd8 librrds-perl libsdl1.2debian libslang2
libsmbclient libsndfile1 libsqlite3-0 libsystemd0 libtcmalloc-minimal4 libtemplate-perl libterm-readline-gnu-perl
libtext-charwidth-perl libtext-iconv-perl libtiff5 libudev1 libuuid-perl libvorbis0a libvorbisenc2 libwbclient0 libwebp6
libwebpmux3 libxml-libxml-perl libxml-parser-perl libxml2 libxslt1.1 libxtables12 libyaml-libyaml-perl locales mawk nmap
nmap-common perl perl-base postfix procmail python-pastedeploy-tpl python-six python2 python2-minimal python2.7
python2.7-minimal python3 python3-apt python3-ceph-argparse python3-ceph-common python3-cephfs python3-cffi-backend
python3-chardet python3-distutils python3-lib2to3 python3-lxml python3-mako python3-markupsafe python3-minimal
python3-pastedeploy python3-pycurl python3-rados python3-rbd python3-rgw python3-simplejson python3-six python3-yaml
rsyslog samba-common samba-libs smbclient sqlite3 systemd udev xfsprogs
The following packages will be upgraded:
adduser apparmor apt apt-listchanges apt-utils attr base-files base-passwd bash bash-completion bc bind9-host binutils
binutils-common binutils-x86-64-linux-gnu bridge-utils bsd-mailx bsdmainutils bsdutils btrfs-progs busybox bzip2
ca-certificates cifs-utils console-setup console-setup-linux coreutils cpio cron cryptsetup-bin dash dbus debconf
debconf-i18n debian-archive-keyring debian-faq debianutils diffutils dirmngr dmeventd dmidecode dmsetup dnsutils
doc-debian dosfstools dpkg dtach e2fsprogs ebtables efibootmgr eject faketime fdisk fdutils file findutils fontconfig
fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fonts-noto-mono fuse gdbm-l10n
genisoimage gettext-base glusterfs-client glusterfs-common gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client
gpg-wks-server gpgconf gpgsm gpgv grep grub-common grub-efi-amd64-bin grub-efi-ia32-bin grub-pc grub-pc-bin grub2-common
gsfonts gzip hdparm hostname idn imagemagick-6-common init init-system-helpers initramfs-tools initramfs-tools-core ipset
iputils-ping isc-dhcp-client isc-dhcp-common iso-codes kbd keyboard-configuration keyutils klibc-utils kmod krb5-locales
less libacl1 libacl1-dev libaio1 libanyevent-http-perl libapparmor1 libappconfig-perl libarchive13 libassuan0 libasyncns0
libattr1 libattr1-dev libaudit-common libaudit1 libavahi-client3 libavahi-common-data libavahi-common3 libbabeltrace1
libbind9-161 libbinutils libblas3 libblkid1 libbsd0 libbz2-1.0 libc-l10n libcaca0 libcap-ng0 libcap2 libcap2-bin
libcom-err2 libconvert-asn1-perl libcrypt-random-seed-perl libcryptsetup12 libcups2 libcupsimage2 libdatrie1 libdb5.3
libdbi1 libdbus-1-3 libde265-0 libdebconfclient0 libdevmapper-event1.02.1 libdevmapper1.02.1 libdigest-hmac-perl libdw1
libedit2 libefiboot1 libefivar1 libelf1 libencode-locale-perl libestr0 libexpat1 libext2fs2 libfaketime libfastjson4
libfdisk1 libfile-chdir-perl libfile-listing-perl libfontconfig1 libfribidi0 libfstrm0 libfuse2 libfuse3-3 libgcrypt20
libgdbm-compat4 libgdbm6 libgeoip1 libgfapi0 libgfchangelog0 libgfrpc0 libgfxdr0 libglib2.0-0 libglusterfs-dev
libglusterfs0 libgmp10 libgnutls-openssl27 libgnutls30 libgnutlsxx28 libgomp1 libgpg-error0 libgraphite2-3
libgssapi-krb5-2 libharfbuzz0b libhtml-tagset-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libibverbs1
libice6 libidn11 libidn2-0 libijs-0.35 libio-html-perl libio-multiplex-perl libio-socket-ssl-perl libirs161 libisccc161
libisccfg163 libiscsi7 libisns0 libjansson4 libjbig2dec0 libjpeg62-turbo libjs-bootstrap libjs-jquery libjs-sphinxdoc
libjs-underscore libjson-perl libk5crypto3 libkeyutils1 libklibc libkmod2 libkrb5-3 libkrb5support0 libksba8 libldap-2.4-2
libldap-common libleveldb1d liblmdb0 liblockfile-bin liblockfile1 liblognorm5 libltdl7 liblttng-ust-ctl4 liblttng-ust0
python-tempita python-waitress python-webob python-webtest python-werkzeug python3-asn1crypto
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
bind9-dnsutils bind9-libs bsdextrautils fonts-urw-base35 gcc-10-base libapt-pkg6.0 libcbor0 libcrypt1 libctf-nobfd0
libctf0 libdns-export1110 libdns1110 libevent-2.1-7 libffi7 libfido2-1 libgcc-s1 libglusterd0 libhogweed6 libipset13
libisc-export1105 libisc1105 libjson-c5 libmaxminddb0 libmd0 libnettle8 libnsl2 libopeniscsiusr libperl4-corelibs-perl
libprocps8 libreadline8 libuv1 libxxhash0 logsave mailcap manpages-dev media-types ncal pci.ids runit-helper uuid-runtime
The following packages have been kept back:
ceph ceph-base ceph-common ceph-fuse ceph-mds ceph-mgr ceph-mgr-modules-core ceph-mon ceph-osd chafa curl gdisk
ghostscript groff-base iproute2 iptables libanyevent-perl libapt-pkg-perl libasound2 libasound2-data libauthen-pam-perl
libc-bin libc-dev-bin libc6 libc6-dev libcairo2 libcephfs2 libchafa0 libclone-perl libcommon-sense-perl
libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcrypt-ssleay-perl libcupsfilters1
libcurl3-gnutls libcurl4 libfilesys-df-perl libflac8 libfreetype6 libgfortran5 libgoogle-perftools4 libgs9 libgs9-common
libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libheif1 libhtml-parser-perl libhttp-message-perl libiptc0 libjemalloc2
libjson-xs-perl liblcms2-2 liblinux-inotify2-perl liblocale-gettext-perl liblua5.3-0 libmagickcore-6.q16-6
libmagickwand-6.q16-6 libnet-dbus-perl libnet-ssleay-perl libnspr4 libnss-systemd libopenjp2-7 libopus0 libpam-systemd
libpixman-1-0 libpng16-16 libpulse0 libpython2-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib
libpython3-stdlib librados2 libradosstriper1 librbd1 librdkafka1 librgw2 librrd8 librrds-perl libsdl1.2debian libslang2
libsmbclient libsndfile1 libsqlite3-0 libsystemd0 libtcmalloc-minimal4 libtemplate-perl libterm-readline-gnu-perl
libtext-charwidth-perl libtext-iconv-perl libtiff5 libudev1 libuuid-perl libvorbis0a libvorbisenc2 libwbclient0 libwebp6
libwebpmux3 libxml-libxml-perl libxml-parser-perl libxml2 libxslt1.1 libxtables12 libyaml-libyaml-perl locales mawk nmap
nmap-common perl perl-base postfix procmail python-pastedeploy-tpl python-six python2 python2-minimal python2.7
python2.7-minimal python3 python3-apt python3-ceph-argparse python3-ceph-common python3-cephfs python3-cffi-backend
python3-chardet python3-distutils python3-lib2to3 python3-lxml python3-mako python3-markupsafe python3-minimal
python3-pastedeploy python3-pycurl python3-rados python3-rbd python3-rgw python3-simplejson python3-six python3-yaml
rsyslog samba-common samba-libs smbclient sqlite3 systemd udev xfsprogs
The following packages will be upgraded:
adduser apparmor apt apt-listchanges apt-utils attr base-files base-passwd bash bash-completion bc bind9-host binutils
binutils-common binutils-x86-64-linux-gnu bridge-utils bsd-mailx bsdmainutils bsdutils btrfs-progs busybox bzip2
ca-certificates cifs-utils console-setup console-setup-linux coreutils cpio cron cryptsetup-bin dash dbus debconf
debconf-i18n debian-archive-keyring debian-faq debianutils diffutils dirmngr dmeventd dmidecode dmsetup dnsutils
doc-debian dosfstools dpkg dtach e2fsprogs ebtables efibootmgr eject faketime fdisk fdutils file findutils fontconfig
fontconfig-config fonts-dejavu-core fonts-font-awesome fonts-glyphicons-halflings fonts-noto-mono fuse gdbm-l10n

Progress: [ 58%] [############################################################.

Any idea?
Thank you.
 
Please help - stucked. Cant login via SSH (connection terminated).
Web is running, shows login, but won´t accept my previous root login credentials with "Login failed. Please try again."
Could credentials be changed during update/upgrade or there could be some service not running causing this problem?
Any idea please?
 
Thank you for pointing me to password resetting. But is it possible? Is update/upgrade able to change password without my notice?
 
I don't think the password has been changed. Usually you have forgotten it, the keyboard layout is wrong, the Caps Lock key is pressed, you have selected the wrong realm or it may have been lost in a faulty update.
 
Right now I tried to login directly on server (on HW). root and my PWD works without problem. I´m logged into debian. Will try to repair SSH. But same user/pwd wont work in Proxmox.
Attached is screen photo...
 

Attachments

  • pve.jpg
    1,023.4 KB · Views: 6
It is unlikely that the password does not work on PVE. Is the realm correct? Is the keyboard layout correct? No caps lock active?
 
Right now I tried to login directly on server (on HW). root and my PWD works without problem. I´m logged into debian. Will try to repair SSH. But same user/pwd wont work in Proxmox.
Attached is screen photo...

1. Remove the 3.9 script that might mess up your ssh if it is something in your .bashrc? Rest see post from sb-jw.
 
So, after reboot - it works. Can log in. Thank you.
Still version 6.4-15. Now will try to step-by-step to update to V7 and after V8. Or I can update directly to V8?
 
You already have some older hardware running, you should first check which version is safe for you. You have to do one version at a time, you can't jump straight to 12.
 
So, after reboot - it works. Can log in. Thank you.
Still version 6.4-15. Now will try to step-by-step to update to V7 and after V8. Or I can update directly to V8?
Backup and restore might be quicker then two major upgrades.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!