[SOLVED] Stuck at (initramfs) with kernel 5.3.13-1-pve


Feb 25, 2018

I just updated from ProxmoxVE 5.x to 6.1-5 after reboot I'm stuck at (initramfs) prompt.

If I run "zpool import -R / rpool" in (initramfs) prompt I have the following error:
cannot import 'zpool' : pool was previously in use from another system.
Last accessed by <unknown> (hostid=0) ...

2020-01-07 22_13_26-Window.jpg

If I reboot from GRUB the hold kernel 4.15.18-24-pve everything is fine.

Thanks for any help!
Last edited:
Hmm - probably the hostid stored in the initramfs of 4.15.18-24 is also 0 ...

Regarding fixing this - you should be able to run:
zpool import -f
(or `zpool import -f rpool`)

and then continue booting with the new kernel (by hitting Ctrl+D)
afterwards you should run
update-initramfs -k all -u

I hope this helps!

Out of curiosity - how and with which version was the system initially setup ? (I guess with the PVE-Installer)
How did you do the upgrade (I guess following the in-place upgrade instructions (using `apt dist-upgrade`))
Glad you resolved your issue!
Please mark the thread as 'SOLVED' - it could help others in a similar situation


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!