[SOLVED] Strange error on CT's shutdown (unregister_netdevice)

fireon

Well-Known Member
Oct 25, 2010
3,066
194
63
Austria/Graz
iteas.at
Hello all,

If i shutdown one of my container (gentoo) from PVE, after timeout the container crashes. If i shutdown it inside the CT it works (acpi is on). But on both situations i get this strange error, all 5 seconds. For about 10 Minutes.
Code:
Message from syslogd@pvehost at Apr 3 01:45:25 ...
kernel:[210333.954073] unregister_netdevice: waiting for lo to become free. Usage count = 3
Here is my configuration.
Code:
arch: amd64
cores: 4
cpuunits: 512
description: Gentoo
hostname: gentoo.tux.local
memory: 2048
net0: name=eth0,bridge=vmbr0,hwaddr=47:05:AE:84:35:AB,ip=dhcp,ip6=auto,type=veth
onboot: 1
ostype: gentoo
parent: snap01
rootfs: local-zfs:subvol-124-disk-0,acl=1,size=45G
swap: 512
lxc.cgroup.devices.allow: c 212:* rwm
lxc.mount.entry: /dev/dvb dev/dvb none bind,optional,create=dir
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
748
80
28
This was an old kernel bug (before version 4.13 I think), but there are apparently other cases where this can happen. Can you post `pveversion -v`? Also maybe describe what's running on this container exactly? I'm seeing some DVB stuff. Does this happen with other containers at all?
 

fireon

Well-Known Member
Oct 25, 2010
3,066
194
63
Austria/Graz
iteas.at
Code:
proxmox-ve: 5.3-1 (running kernel: 4.15.18-12-pve)
pve-manager: 5.3-12 (running version: 5.3-12/5fbbbaf6)
pve-kernel-4.15: 5.3-3
pve-kernel-4.15.18-12-pve: 4.15.18-35
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-48
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-12
libpve-storage-perl: 5.0-39
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-24
pve-cluster: 5.0-34
pve-container: 2.0-35
pve-docs: 5.3-3
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-18
pve-firmware: 2.0-6
pve-ha-manager: 2.0-8
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-2
pve-xtermjs: 3.10.1-2
pve-zsync: 1.7-3
qemu-server: 5.0-47
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
It's only on this container, I thought that was Gentoo.
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
748
80
28
I can't reproduce this problem with a regular Gentoo container. Also tried with the mount entry from your config, didn't make any difference.

Your package versions and the kernel also looks normal and up to date.

Must be something with whatever is running in the container? Can you describe a bit more?
 

fireon

Well-Known Member
Oct 25, 2010
3,066
194
63
Austria/Graz
iteas.at
Yes you are right. It is depending on the dvbcard. If i remove the two special configlines, the message is gone away.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!