[SOLVED] stop ring0 does not start ring1 (redundant ring)

HFernandez

Active Member
May 20, 2019
16
1
43
124
Hi, I decided to do a Redundant Ring Protocol in an existing cluster
for corosync communication,
I have followed all the steps of the help that comes in the nodes,
but when I turn off the ports of the ring0 I lose communication with the nodes, only the VMs still have communication.

VMs use a separate bond with their ip 192.168.10.2
the ring0 has its own ip 192.168.11.2
the ring1 another ip 192.168.12.2

roxmox-ve: 5.4-1 (running kernel: 4.15.18-12-pve)
pve-manager: 5.4-3 (running version: 5.4-3 / 0a6eaa62)
pve-kernel-4.15: 5.3-3
pve-kernel-4.15.18-12-pve: 4.15.18-35
corosync: 2.4.4-pve1

Should I configure something else?
 
Hi,

please send the /etc/pve/corosync.conf
and the network setting.
Should I configure something else?
Because none can say what you have configured.
 
Hi Wolfgang, I had a bad mask on the net used by ring0 and ring1, I had a very large mask and reduced it to 255.255.255.0.
After that try again and everything works ok.
Thank you
 
Glad to hear you found the problem.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!