start pxe over ipv4

Patrik Stenfeldt

New Member
Jan 6, 2019
I was about to try out gpu passthrough in proxmox 5.3.
A few days ago i tried it in unraid and it worked fine until i tried to reboot and got the error 43 message.

Well, back to proxmox. Whenever i change BIOS to OVMF i get start pxe over ipv4 even from trying to boot the install iso.
If i try to install lubuntu it freezes somewhere in the beginning of loading the livecd.

Where do i even start to search? (Im a beginner, remember, but i have read a few tutorials including the one on the wiki)
did you change the boot order? VM-> options
can you post your vm config and pveversion -v ?
bios: ovmf
boot: dcn
bootdisk: scsi0
cores: 2
efidisk0: local-lvm:vm-101-disk-1,size=128K
ide2: local:iso/lubuntu-18.10-desktop-amd64.iso,media=cdrom
memory: 8192
name: lubuntuefi
net0: virtio=XX:XX:XX:XX:XX:XX,bridge=vmbr0
numa: 0
ostype: l26
scsi0: local-lvm:vm-101-disk-0,size=32G
scsihw: virtio-scsi-pci
sockets: 2

pveversion -v
proxmox-ve: 5.3-1 (running kernel: 4.15.18-9-pve)

pve-manager: 5.3-5 (running version: 5.3-5/97ae681d)
pve-kernel-4.15: 5.2-12
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-43
libpve-guest-common-perl: 2.0-18
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-33
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-5
lxcfs: 3.0.2-2
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-31
pve-container: 2.0-31
pve-docs: 5.3-1
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-16
pve-firmware: 2.0-6
pve-ha-manager: 2.0-5
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-1
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-43
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1
mhmm works here, you could try to set the boot order to 'cdn' (so that the cdrom comes first)
Hmm... In options the cdrom clearly comes first, but not in the config.. Ill edit the config manually and try again.
Though, it clearly boots from cd, its soon after boot it halts.

Can there be some (host)bios settings that makes everything break?
Though, it clearly boots from cd, its soon after boot it halts.
mhmm? so it boots correctly from the cdrom?

if you installed the vm in bios mode, you cannot simply boot it in efi mode, you would have to convert the install or reinstall the guest then
It boots correctly from cdrom, yes but halts just a second later, i get the option to check cdrom for errors etc (which by the way works) but as soon as i try to boot it halts.

Same thing with win10, i get the "press any key to boot from cdrom..." but as soon as it starts to boot i get the pxe error.
I just reinstalled the host to exclude any changes i might have made, followed the theps in the pci passthrough tutorial, set up a new windows guest and..

...still the same error.
correction: it seems like i have been to slow to press the key for cdrom boot, i got windows to start installing now.
But still, windows normally detects that there are no filesystem on disk and start booting from cd anyways.

well, i guess i have to continue to see if i can manage to get lubuntu to boot. Seems like proxmox is doing its job even though there is room for improvement.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!