Standalone node - no cluster defined

ChrisJM

Active Member
Mar 12, 2018
50
1
28
38
Hello.

I think i made a mistake and ran "pvecm expected 1" on the wrong node when removing a node. now on all my nodes its showing "Standalone node - no cluster defined"

I have tried to restart the cluster service but has made no difference.

How do i fix this issue?
 
this is the pvecm status

root@CLOUD1415:~# pvecm status
Quorum information
------------------
Date: Mon Jun 17 14:33:55 2019
Quorum provider: corosync_votequorum
Nodes: 3
Node ID: 0x00000002
Ring ID: 1/1320
Quorate: Yes

Votequorum information
----------------------
Expected votes: 3
Highest expected: 3
Total votes: 3
Quorum: 2
Flags: Quorate

Membership information
----------------------
Nodeid Votes Name
0x00000001 1 81.27.99.27
0x00000002 1 81.27.99.28 (local)
0x00000003 1 81.27.99.29
 
Have you tried simply resetting the value to its default ("pvecm expected 3") on each node?

I would then reboot the nodes one-by-one (resetting the value after boot) to make sure no further split-brain situations will occur.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!