[SOLVED] Standalone node - no cluster defined

sky_me

Member
Dec 27, 2021
10
0
6
23
My pve6.4 cluster is abnormal in communication between hosts due to network problems, and some hosts break down and restart. After the host is restarted, the virtual host is normal, but the cluster status changes to Standalone Node: Cluster not defined. But now I can also manage entire clusters and hosts and virtual machines from a single host。
After performing the following operations on the cluster, the cluster became an Independent Node with "Cluster not defined" status:
  1. Due to a network outage that caused the host to restart, I restarted the entire cluster's hosts.
  2. Accidentally deleted the entire /etc/pve/node directory from one of the cluster nodes.
  3. On node1, regenerated the certificate using pvecm updatecerts -f.
  4. After generating the certificate, I restarted the entire cluster's hosts due to issues with the cluster status.
After completing these operations, the cluster recovered, but it became an Standalone Node with "no Cluster defined" status.
1689061365382.png
 
I solved the problem mainly because of the pve-ssl.pem certificate of node node7 in my cluster, the certificate size is 0kb. I copied the pve-ssl.key and pve-ssl.pem files from one of the excluded nodes in the cluster, and the cluster displayed normally. But I'm not sure that copying certificates from other online nodes is a problem. You should pay attention to this.
1689072885916.png
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!