[SOLVED] SSH is inaccessible over IPv6 on thunderbolt interfaces?

scyto

Active Member
Aug 8, 2023
310
55
28
I setup a promox v8 cluster.

I have 3 nodes where NIC 1 is connected to a LAN - this is purely using IPv4.
NIC2 (thunderbolt direct connection) on each node are purely using IPv6

  • I can ping -6 node 3 from node 1.
  • I can curl the 8006 port on node 3 from node 1 over IPv6 ok
  • I can't access SSH port 22 on node 3 from node 1

I checked:
  1. that sshd is listening on both 0.0.0.0 and ::
  2. that the firewall is off at the cluster level and that there are no IPTables whatsoever

At this point i am stumped (but i am new to proxmox...)
 
This is also affecting ceph on port 3300 - i can see it is listening on <ipv6add>:3300 and a bunch of other ports, but when i setup node two of ceph i get "Could not connect to ceph cluster despite configured monitors" and i get no connection if i try and curl the ports.

I am stumped.
 
This seems to be caused by a bug when only using thunderbolt interfaces.

Marking as solved as I now know the cause.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!