[SOLVED] SSH from local network fails after login


New Member
Jul 13, 2023
I have a new Proxmox VE 8.0 environment with an Ubuntu 22.04.2 guest VM running.

When I ssh to the guest VM from another device on my local network, it connects and allows login but then after maybe 30 seconds the connection goes down and future attempts to connect to the Ubuntu guest via ssh are met with a connection refused error.

If I go to the Proxmox shell and ssh to the guest VM, the ssh works perfectly so the issue seems to be in connecting from outside the Proxmox host.

Has anyone experienced similar or can offer advice on where to look to find some clues on the issue?

Thanks in advance
On a hunch:
* check for duplicate IPs and duplicate MAC addresses in your network
* additionally make sure that all devices agree on the netmasks in your network

If this does not help - and the journal of the node or the guest show no hints what's wrong - I'd suggest to use tcpdump to see where the packets might get lost...
Great hunch - it was an IP address conflict with another device already on the network vs. the fixed IP I assigned the VM at creation.

Changed the DHCP pool on the network to create a protected space for fixed IP devices and restarted everything, solved :)
  • Like
Reactions: Stoiko Ivanov
Nice :) glad that worked out so fast


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!