Spice geht plötzlich nicht mehr

bobx

Member
Jul 12, 2018
61
1
13
Hallo miteinander,

ich habe verschiedene VMs, auf die ich per Spice-Konsole zugreife. Das lief alles die letzten Monate wunderbar. Heute wird mir plötzlich beim Klick auf den Button >Konsole ein Download-Fenster angeboten, über das ich einen neuen Namen angeben und die Spice-Datei speichern könnte.

Eigentlich habe ich nichts gemacht. Lediglich ein Update bei meiner Workstation, von der aus ich die VMs per Spice aufrufe.
Ich hab schon den virt-viewer einmal deinstalliert und wieder frisch installiert. Das hat nichts geholfen. Auch ein Neustart der Systeme war nicht hilfreich. Im Syslog gibt es beim Knopfdruck auf >Konsole keine Ausgabe von Hinweisen/Fehlern.

Was kann ich noch noch machen? Hat jemand Tipps?

Proxmox ist der VE 7.1.10, Workstation ist ein Linux Mint.
Browser ist Firefox.

Dank und Gruß
bobx
 
Last edited:

bobx

Member
Jul 12, 2018
61
1
13
Kleine Ergänzung: Wenn ich die Datei tatsächlich speichere und dann doppelt anklicke, dann geht der virt-viewer ran und öffnet die Konsole. Das klappt. Ist aber irgendwie unschön. Da scheint die Spice-Kennung verloren gegangen zu sein. Der Firefox kennt prinzipiel die Anwendung Spice und weiß, dass er das mit dem Virt-Manager öffnen muss. Tut er aber nicht automatisch.
 

Dunuin

Famous Member
Jun 30, 2020
8,990
2,310
156
Germany
Was mir bei Win11 aufgefallen ist, ist dass man seit kurzer Zeit für jeden Dateityp einzeln eine Standard-App auswählen muss. So kann man nicht mehr so leicht von Edge zu Chrome/Opera/Firefox wechseln, weil man jetzt für dutzende Dateitypen wie ".htm", ".html", ".xhtml" einzeln von Edge zum Browser der Wahl wechseln muss. War wohl sonst zu einfach nicht den Edge zu benutzen.
Vielleicht hängt das damit irgendwie zusammen?
 

bobx

Member
Jul 12, 2018
61
1
13
Was mir bei Win11 aufgefallen ist, ist dass man seit kurzer Zeit für jeden Dateityp einzeln eine Standard-App auswählen muss. So kann man nicht mehr so leicht von Edge zu Chrome/Opera/Firefox wechseln, weil man jetzt für dutzende Dateitypen wie ".htm", ".html", ".xhtml" einzeln von Edge zum Browser der Wahl wechseln muss. War wohl sonst zu einfach nicht den Edge zu benutzen.
Vielleicht hängt das damit irgendwie zusammen?
Hui - das klingt nervig.
Mit Windows hat das bei mir vermutlich nichts zu tun. Ich hab ja ein Linux Mint.
Hmmm ...
 
Sep 11, 2017
48
5
33
54
Wien
www.pinguin-systeme.at
Bei mir ist das Problem noch etwas größer: über Chrome/Chromium/... wird die .vv geholt, der Spice-Viewer (virt-viewer) geht kurz auf, dann erscheint eine Fehlermeldung "Verbindung zum Grafik-Server /pfad/zum/File/pve-spice.vv kann nicht hergestellt werden"
Das ist seit dem vorletzten pve update so.

Seit dem Upgrade auf pve 7.1 weigert sich curl, das selbstsignierte Zertifikat anzunehmen.... Das funktioniert nur mehr auf älteren Debian und Raspian Versionen, aktuelle Versionen von (k)ubuntu und opensuse haben das Problem alle.

Hat da jemand Ideen dazu?
 

silberikus

New Member
Jan 23, 2023
2
0
1
77948 Friesenheim
Hallo in die Runde,
zu dem ursprünglichen Problem, dass die Konsolen-Datei (*.vv) nicht automatisch geöffnet wird habe ich im Firefox eine Lösung gefunden.

Man muss Firefox beibringen, dass die VirtViewer-Dateien mit der Anwendung REMOTE-VIEWER.EXE geöffnet bzw. ausgeführ werden.

Einstellungen dazu anpassen:

Im Firefox in die Einstellungen gehen und als Suchbegriff ÖFFNEN eingeben. Als Ergebnis erhält man u.a. eine Liste mit den Dateiendungen, die Firefox automtisch verarbeitet. In der Liste die Endung "vv" bzw. "VirtVIewer connection file" finden und kontrollieren, was Firefox damit macht. Es sollte "Mit remote-viewer.exe öffnen (Standard)" sein. Dann öffnet Firefox die VirtViewer-Konfigurationen automatisch. Falls in der Liste was anderes steht den Eintrage löschen. Unter der Liste mit den Dateiendunge muss dann noch bei der Frage WIE SOLL FIREFOX MIT ANDEREN DATEIEN VERFAHREN? die Option "FRAGEN, OB DATEIEN GEÖFFNET ODER GESPEICHERT WERDEN SOLLEN" aktiviert werden.
Jetzt nochmal versuchen, eine Konsole zu starten. Firefox sollte jetzt fragen, was mit der VV-Datei gemacht weden soll. Hier dann auf "Ausführen mit VirtViewer" umschalten und die Options "Immer diese Aktion ausführen setzen"
Ab jetzt sollte beim Klick auf KONSOLE wieder automatisch eine Konsolensitzung starten.

Ich vermute nach dem Prinzip funktioniert das auch in den anderen Browsern.

Ich hoffe, das hilft euch weiter.

Gruß Thorsten
 
Jul 16, 2018
11
2
23
Hmm - geht auch einfacher. Hatte dasselbe Problem.
Dazu (zumindest im Firefox) die Downloads anzeigen. Dort Rechtsklick auf die virt-viewer Datei und "ähliche Dateien immer öffnen" auswählen. Das ist dann meist schon dem VIRT-Viewer zugeordnet.
 
  • Like
Reactions: UdoB

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!