[SOLVED] Spice error unable connect to graphic server?

admjral3

New Member
Dec 22, 2020
10
1
3
27
I clicked and it opened immediately, the screen was connecting to graphic server and after 3 or 5 second ,unable to connect to.....like in picture
 

admjral3

New Member
Dec 22, 2020
10
1
3
27
Please check the journalctl -f during open it again.
Jan 14 16:09:33 pve systemd[56138]: Listening on D-Bus User Message Bus Socket.
Jan 14 16:09:33 pve systemd[56138]: Reached target Sockets.
Jan 14 16:09:33 pve systemd[56138]: Reached target Basic System.
Jan 14 16:09:33 pve systemd[56138]: Reached target Default.
Jan 14 16:09:33 pve systemd[56138]: Startup finished in 55ms.
Jan 14 16:09:33 pve systemd[1]: Started User Manager for UID 0.
Jan 14 16:09:33 pve systemd[1]: Started Session 19 of user root.
Jan 14 16:09:33 pve spice-vdagentd[38568]: Error getting active session: No data available
Jan 14 16:09:33 pve spice-vdagentd[38568]: Error getting active session: No data available
Jan 14 16:09:33 pve login[56153]: ROOT LOGIN on '/dev/pts/0'
 

admjral3

New Member
Dec 22, 2020
10
1
3
27
is that occur on other VM or only on windows 7?
I can not use spice for all vms and also can not install windows 7 64 bit, if i have subscription so you can help me to solve immediately?
 
Last edited:

admjral3

New Member
Dec 22, 2020
10
1
3
27
please post the output of pveversion -v
proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-2 (running version: 6.3-2/22f57405)
pve-kernel-5.4: 6.3-1
pve-kernel-helper: 6.3-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libproxmox-backup-qemu0: 1.0.2-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-6
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.3-1
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.5-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-3
pve-cluster: 6.2-1
pve-container: 3.3-1
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-7
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-1
smartmontools: 7.1-pve2
spiceterm: 3.1-1
Uncerm: 1.6-2
zfsutils-linux: 0.8.5-pve1
 

Moayad

Proxmox Staff Member
Staff member
Jan 2, 2020
742
62
28
27
Vieena
shop.maurer-it.com
What is the virt-viewer version, also check if port 3128 is open on your node ss -a -4 | grep 3128 and firewall if enabled pve-firewall status?
 

admjral3

New Member
Dec 22, 2020
10
1
3
27
What is the virt-viewer version, also check if port 3128 is open on your node ss -a -4 | grep 3128 and firewall if enabled pve-firewall status?
i use lastest ver virt-viewer 9.0 for client
root@pve:~# virt-viewer
Unable to init server: Could not connect: Connection refused

(virt-viewer:41996): Gtk-WARNING **: 21:14:41.013: cannot open display:
root@pve:~# ss -a -4 | grep 3128
tcp LISTEN 0 128 0.0.0.0:3128 0.0.0.0:*
root@pve:~# pve-firewall status
Status: disabled/running
 
Last edited:

Moayad

Proxmox Staff Member
Staff member
Jan 2, 2020
742
62
28
27
Vieena
shop.maurer-it.com
Glad you solved your issue!

Please mark the thread as [SOLVED] to help other people who have the same issue Thanks!

Have a nice day :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!