[SOLVED] Some clients can't login - due to invalid "english" language. (Actual issue: password helper!)

MrPete

Active Member
Aug 6, 2021
123
57
33
66
Initial symptoms...

This is just... strange. On many clients, I have no issues logging in to ProxMox.
On a few, suddenly I can't. Used to work but not anymore.

The symptom: clicking on the login button does nothing at all. ALWAYS. No errors. It just does nothing.
I have no blockers in place.

On more detailed examination:
  • The language entry, which says "English" is red-bounded as if in error. The (i) error says "value 'English' not allowed."
  • If I attempt to select "Default - English" I get the same.
  • If I select another language, the dialog box does change to that language, but the entry shown remains "English" and has the same error.

Diagnosed and solved:
  • My password/form helper remembered an earlier version of the login form
  • It used to use "English" but now uses "Default (English)"
  • By forcing "English" into the form field, it silently made it impossible to login
Such fun :cool:
 
Hi

Same kind of problem for me.

I have a cluster with 3 nodes, but I can't login in english on one of them !?!? (Ok in english on tow other). I have to use french for the connection.
 

Attachments

  • Capture d’écran du 2024-05-07 14-29-06.png
    Capture d’écran du 2024-05-07 14-29-06.png
    15.6 KB · Views: 3
  • Capture d’écran du 2024-05-07 14-28-40.png
    Capture d’écran du 2024-05-07 14-28-40.png
    12.4 KB · Views: 3
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!