-SOLVED- Zpool replacing drive problem.

STE

New Member
May 15, 2019
6
0
1
31
Hi,

I'm testing proxmox with raidz1 and I'm having some problems when trying to replace the disk, I've followed zfs tips and tricks article but I'm stuck, this is what I've done so far:

1) removed one of the disks. (SDB)
2) Set the disk as offline
3) Replaced the disk
4) Replicated partition tables from SDA
5) Randomized the guis
6) installed grub
7) Then I try to replace the disk on the zfs pool:
zpool replace rpool /dev/sdb2

But I get the following error:

Invalid vdev specification
use'-f' to ovveride the following errors:
/dev/sdb2 contains a filesystem of type 'ext3'

I'm about to delete all partitions on the new drive and try again, any other ideas?

Thanks.

-EDIT: I deleted every single partition on the disk and tried again but I'm still getting the same exact error.

-EDIT2: Ok, so apparently, the problem was that I typed sdb2 instead of sdb3, for some reason all my sd have the number 3 after them, but I was typing sdb2 like the article reads.
THanks.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!