[SOLVED] pve-firmware package error when installing Proxmox 8 over Debian 12 Bookworm

chicagonyc

New Member
Jan 28, 2023
11
1
3
Hello. I'm aiming to install Proxmox 8 over a Debian 12.1 install. This is a machine running a Ryzen 3700X on a B350 motherboard with 64Gb RAM and an NVME boot drive. I have previously ran Linux without any issues on this computer. And the new Debian 12 Bookworm install works perfectly: can access the network, display works, drives show up, no problems.

I am following the official tutorial about install Proxmox over a new Debian install that is fully upgraded. The instructions are actually for Bullseye but the updates I thought would be pretty straightforward for Bookworm.

I successfully edited /etc/hosts, added the repositories, added the GPG key.

The part I'm having a problem with is installing PVE kernel 6.2 (apt install pve-kernel-6.2). Most of the packages installed fine, but not pve-firmware. I'm getting the following inscrutable error:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
pve-firmware
Suggested packages:
linux-image
The following NEW packages will be installed:
pve-firmware
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/76.0 MB of archives.
After this operation, 240 MB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 274131 files and directories currently installed.)
Preparing to unpack .../pve-firmware_3.7-1_all.deb ...
Unpacking pve-firmware (3.7-1) ...
dpkg: error processing archive /var/cache/apt/archives/pve-firmware_3.7-1_all.de
b (--unpack):
trying to overwrite '/lib/firmware/ath9k_htc/htc_7010-1.4.0.fw', which is also
in package firmware-ath9k-htc 1.4.0-108-gd856466+dfsg1-1.3
Errors were encountered while processing:
/var/cache/apt/archives/pve-firmware_3.7-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm not quite sure why there's some sort of conflict here, and what to do about it.

I did try to uninstall firmware-ath9k-htc which doesn't apply to me (I don't have a Wireless USB adapter -- I'm using wired ethernet). But that doesn't work either:

apt remove firmware-ath9k-htc
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
proxmox-kernel-6.2 : Depends: pve-firmware but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
And trying apt --fix-broken install just starts the same results as above. I seem to be stuck.

Update: Figured it out. The key was removing firmware-ath9k-htc. But I needed to force that removal. Once I did that, apt --fix-broken-install worked perfectly.
 
Last edited:
  • Like
Reactions: Mody
Hello everyone,

I have just found this entry. Very good, I was able to solve it with two installations. Will this be fixed in the next Proxmox version? Is it a bug? I have now had the problem on two completely independent Debian 12 systems!

Thank you!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!