SOLVED - Packages have been kept back

Karsten

Member
Sep 6, 2016
6
1
23
Berlin
Hi.

I cannot upgrade our productive environment (licensed enterprise) to 6.3. The packages are kept back.

In the WebGUI, the upgrade button is also greyed out.

Best
Karsten


Bash:
root@XXX:/etc/apt/sources.list.d# apt-get update && apt-get dist-upgrade && apt-get autoremove && apt-get autoclean
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://mirror.hetzner.de/debian/packages buster InRelease                                 
Hit:3 http://mirror.hetzner.de/debian/security buster/updates InRelease                         
Hit:4 http://mirror.hetzner.de/debian/packages buster-updates InRelease                         
Hit:5 http://ftp.de.debian.org/debian buster InRelease                                           
Hit:6 http://ftp.de.debian.org/debian buster-updates InRelease                                                   
Hit:7 https://packages.icinga.com/debian icinga-buster InRelease                                                 
Hit:8 https://enterprise.proxmox.com/debian/pve buster InRelease                           
Reading package lists... Done           
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libpve-storage-perl pve-container pve-manager
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
root@XXX:~# apt list --upgradable
Listing... Done
libpve-common-perl/stable 6.3-2 all [upgradable from: 6.2-2]
libpve-storage-perl/stable 6.3-3 all [upgradable from: 6.2-9]
pve-container/stable 3.3-2 all [upgradable from: 3.2-2]
pve-manager/stable 6.3-3 amd64 [upgradable from: 6.2-12]
qemu-server/stable 6.3-2 amd64 [upgradable from: 6.2-15]
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,217
1,134
164
hmm - one specific thing from that output is the configured icinga repository - could you try temporarily removing it and running `apt update; apt full-upgrade` ?

if this does not help - check the output of installing the newer versions of libpve-common-perl and libpve-storage-perl:
Code:
apt install libpve-common-perl=6.3-2
apt install libpve-storage-perl=6.3-3

(this should provide more output why it does not get upgraded)

I hope this helps!
 

Karsten

Member
Sep 6, 2016
6
1
23
Berlin
Hi.

Yeeeeees - pointed me to the right direction.

There is a bug in a needed package - in libyaml-libyaml-perl. So after installing it despite the open bug report, the upgrade worked.

Thank you!
Karsten


Bash:
root@webXX:~# apt upgrade libpve-common-perl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpve-common-perl : Depends: libyaml-libyaml-perl but it is not installable
E: Broken packages


root@webXX:~# apt-cache showpkg libyaml-libyaml-perl
Package: libyaml-libyaml-perl
Versions:
0.76+repack-1 (/var/lib/apt/lists/ftp.de.debian.org_debian_dists_buster_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.de.debian.org_debian_dists_buster_main_binary-amd64_Packages
                  MD5: 8fa3125a297cb8c4eb3becc6b15ffd1a
 Description Language: en
                 File: /var/lib/apt/lists/ftp.de.debian.org_debian_dists_buster_main_i18n_Translation-en
                  MD5: 8fa3125a297cb8c4eb3becc6b15ffd1a


Reverse Depends:
  libjson-validator-perl,libyaml-libyaml-perl 0.67
  libpve-common-perl,libyaml-libyaml-perl
  libpve-common-perl,libyaml-libyaml-perl
  libpve-common-perl,libyaml-libyaml-perl
  libpve-common-perl,libyaml-libyaml-perl
  umegaya,libyaml-libyaml-perl
  pkg-perl-tools,libyaml-libyaml-perl
  lintian,libyaml-libyaml-perl
  license-reconcile,libyaml-libyaml-perl
  libyaml-perl,libyaml-libyaml-perl
  libxxx-perl,libyaml-libyaml-perl
  libwx-perl-datawalker-perl,libyaml-libyaml-perl
  libtest-yaml-valid-perl,libyaml-libyaml-perl
  libpoet-perl,libyaml-libyaml-perl
  libpar-dist-perl,libyaml-libyaml-perl
  libmoosex-storage-perl,libyaml-libyaml-perl
  libmoosex-simpleconfig-perl,libyaml-libyaml-perl
  libkiokudb-perl,libyaml-libyaml-perl
  libconfig-model-backend-yaml-perl,libyaml-libyaml-perl 0.69
  libhtml-formfu-perl,libyaml-libyaml-perl
  libemail-mime-kit-perl,libyaml-libyaml-perl
  libdancer-perl,libyaml-libyaml-perl
  boxer,libyaml-libyaml-perl
  libconfig-any-perl,libyaml-libyaml-perl
  libcode-tidyall-plugin-yamlfrontmatter-perl,libyaml-libyaml-perl
  libcatmandu-sru-perl,libyaml-libyaml-perl
  libcatmandu-perl,libyaml-libyaml-perl
  libcatmandu-marc-perl,libyaml-libyaml-perl
  ikiwiki,libyaml-libyaml-perl
  duck,libyaml-libyaml-perl
  dh-make-perl,libyaml-libyaml-perl
  ciderwebmail,libyaml-libyaml-perl
Dependencies:
0.76+repack-1 - perl (2 5.28.1-3) perlapi-5.28.1 (0 (null)) libc6 (2 2.11) libyaml-0-2 (0 (null))
Provides:
0.76+repack-1 -
Reverse Provides:


root@webXX:~# apt-get install  libyaml-libyaml-perl=0.76+repack-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  libyaml-libyaml-perl
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 33.1 kB of archives.
After this operation, 94.2 kB of additional disk space will be used.
Get:1 http://ftp.de.debian.org/debian buster/main amd64 libyaml-libyaml-perl amd64 0.76+repack-1 [33.1 kB]
Fetched 33.1 kB in 0s (399 kB/s)               
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of libyaml-libyaml-perl (-> 0.76+repack-1) <Resolved in some Version>
 b1 - #862373 - libyaml-libyaml-perl: Unconditionally instantiates objects from yaml data (Fixed: libyaml-libyaml-perl/0.81+repack-1)
Summary:
 libyaml-libyaml-perl(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] n
**********************************************************************
****** Exiting with an error in order to stop the installation. ******
**********************************************************************
E: Sub-process /usr/sbin/apt-listbugs apt returned an error code (10)
E: Failure running script /usr/sbin/apt-listbugs apt
 
  • Like
Reactions: Stoiko Ivanov

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,217
1,134
164
Glad you found the issue!
Thanks for showing me apt-listbugs! :)
 

Karsten

Member
Sep 6, 2016
6
1
23
Berlin
:)

But apt-listbugs was also part of the problem. I have two Proxmox clusters. One without apt-listbugs, one with it (set up from a former admin). So this was confusing - the one without was updated, the one with not. I could not see a difference. So for me, I removed apt-listbugs now from the 2nd cluster.

Best
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!