So i might have killed my nic.. and basic settings help :)

intercode

New Member
Jan 30, 2019
11
0
1
43
Hello :)

I have my prox running for about a year.. no problems..

but then i decieded to add another nvme disk to the system... but after that, my pcie nic id not working..
it lights up while booting... but as soon as prox has started up.. the light turn of on both ports of the nic...

IS there a way i can reinstall it or even check what is wrong? what loggs do i need to look into?

While i ahve this issue... i decieded to use the internal nic... it is ok for the server... but the VM´s have no internet.. here is a dump of my networks file:


upload_2019-7-4_19-57-16.png
upload_2019-7-4_19-59-12.png


and this picture, is from a random VM on my setup, using th einternal nic :

upload_2019-7-4_20-0-31.png


What am i doing wrong, both on the biggest issue, when the nic pcie is not working... and on the issue on the internal nic?

thank you so much :)
 

Attachments

  • upload_2019-7-4_19-58-35.png
    upload_2019-7-4_19-58-35.png
    32.5 KB · Views: 1
Well... i got the pcie nic to work again... some how it was not set to active... and the prox is connectiong to the local network via the pcie nic..

but still, no mather what i do, none og the vm´s are getting an ip.
upload_2019-7-4_23-21-4.png
upload_2019-7-4_23-21-25.png


and on the VM´s
upload_2019-7-4_23-20-21.png
i tryed every setting...
 

Attachments

  • upload_2019-7-4_23-18-50.png
    upload_2019-7-4_23-18-50.png
    24.1 KB · Views: 1
  • upload_2019-7-4_23-19-17.png
    upload_2019-7-4_23-19-17.png
    11.2 KB · Views: 1
You have to add the NIC which are currently working to the vmbr setting 'bridge-ports'. Currently you have entered 'none' and this is the problem.
 
You have to add the NIC which are currently working to the vmbr setting 'bridge-ports'. Currently you have entered 'none' and this is the problem.
Thansk for your reply...

if i do so - add any of the nic to any og the bdridges.. the server does not come online.. for some strange reason
 
Do not use DHCP on vmbr use static instead and DHCP on the connected interface. As i can see you have set this on vmbr0. If you do not want to use different switch ports for different VMs, you are not need to add multiple vmbr, it's enough to set vmbr0.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!