Snmpd problems


Jun 20, 2018
First if this is to far off topic let me know/move/delete this..

I've got a problem that may or may not be directly related to proxmox: I use net snmp (snmpd) to monitor my servers(dell R720), and today snmp stopped responding to requests on both of them. I believe this was around the same time I brought a link up (it was previously configured, just not patched into the switch.) I verified there were no routing or switch loops or any other network related issues, even to the point of disconnecting these links with the same result. I tried restarting snmpd which took a while, so I checked on this and found that it timed out with the stop command and went to the kill command. After it started back up it did not appear to be listening on the 161 UDP port. So next step.. Purge snmpd from the system and verify there are no snmp processes running, reinstall, same thing. There is nothing in the logs other than the start and stop. The logs are set to 7(debug) What could possibly be going on?
do you have any snmpd related output in the journal? (`journalctl -r`)
else - check for files changing while you start snmpd - maybe it logs somewhere else:
`find /var/log -mmin -5` (find all files in /var/log that were modified in the past 5 mins)

hope this helps!
No, there was nothing in the journal either. I didn't check other files, but can go back in the log to when it was working and find all the output.

I ended up restarting the servers (which was obviously not ideal) and that did it. I'm not sure what got locked in, But the restart fixed it..
Well at least it's running again!
next time you could additionally try to :
* check the status of the snmpd service (`systemctl status -l snmpd`) (not 100% sure how the service is called)
* try to manually start snmpd on the command line and check it's output (`systemctl cat snmpd` should show you what gets executed by systemd)

Please mark your thread as 'SOLVED' so that others know what to expect - Thanks!
Wait is there a way to activate it through the gui? I've always called it through the cli..

When I run status I always get the same few lines. Even in that occurance.
* snmpd is not integrated into the GUI of PVE
What I meant is that you try to start the `snmpd` daemon itself (with the same arguments as systemd would) instead of starting it via `systemctl`


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!