[SOLVED] SNMP not reachable


New Member
Mar 30, 2023
Most probably i'm posting an extremly stupid question, however i seek help:
I use observium for monitoring ststus of my servers, today i installed snmpd on backup server and configured snmp v3 user, however i can not add backup server on observium.

I tested snmp localy with:
snmpwalk -v3 -u admin -l authPriv -a MD5 -A secret -x AES -X passphrase

it works

But when I test it wiyj it's local adress
snmpwalk -v3 -u admin -l authPriv -a MD5 -A secret -x AES -X passphrase
I get:
snmpwalk: Timeout

I gues I need to open port 161 to UDP, but i don't know how to, from what i see nft is disabled by default, SO

The question is, how do i open port 161 on PBS, and where firewall ruleset is stored, and how it's managed ?
Yep, editing snmpd.conf solved the problem, thought default was to listen on all interfaces, and when setting up snmpd on pve it was true, (or i missrember it).For anyone who is reading this later solution is to chage 'agentadress' in snmpd.conf
  • Like
Reactions: Moayad


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!