Snapshots on CEPH

ednt

Active Member
Mar 16, 2017
96
7
28
Hi,
at the weekend we run into a problem:
We made snapshots of windows servers for backups to transport the images.
In one case the windows server immediately rebootet and did not found his boot drive anymore.
We had to completely stop the server and start it again. Then, fortunately, the server comes up again.

We started to search for a reason, but the only thing we found was:

Note
STOP I/O BEFORE snapshotting an image. If the image contains a filesystem, the filesystem must be in a consistent state BEFORE snapshotting.

at
https://docs.ceph.com/docs/giant/rbd/rbd-snapshot/

How is this handled by ProxMox?

Or can there be an other reason for the behaviour of the windows server?
 

Alwin

Proxmox Retired Staff
Retired Staff
Aug 1, 2017
4,617
458
88
STOP I/O BEFORE snapshotting an image. If the image contains a filesystem, the filesystem must be in a consistent state BEFORE snapshotting.
This is true for all filesystems, on any snapshot capable storage.

How is this handled by ProxMox?
The guest-agent needs to be active and installed in the VM. Then the filesystem (Windows VSS) will be notified to flush.
https://pve.proxmox.com/pve-docs/chapter-qm.html#qm_options

Or can there be an other reason for the behaviour of the windows server?
Certainly. Check the Windows & host logs.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!