[SOLVED] Slow networking with Endian, Proxmox, and bridged pppoe Fibre


Renowned Member
Aug 19, 2013
So I had issues with my shiny new 1Gb fibre from Movistar.

Router happily connects to the interwebs but I needed to bridge it back to my Endian box.

That required a PPPoE connection.

If I ran iperf3 round the network everything appeared as expected at around 1Gb, but anything going in or out via Endian did not. The biggest pain is I could not find a iperf package for Endian to prove that was where the issue lay.

After a lot of searching, head scratching and frustration, I happened to find a post in the ClearOS foros:


In short for posterity:

I have a gigabit fiber connection that requires PPPoE. When I enable the PPPoE connection on clear, it reduces me to 100 megabits per second. When I go back to a regular interface and let centurylink's modem do the bridging, I am able to get 800 too 900 megabits down. Is there anyway to fix this? Is this a known bug?

And here are some possible solutions....

I did this and rebooted. Problem solved.

*** this thing to make it an option?
# echo "plugin rp-pppoe.so" >> /etc/ppp/options

An alternative place may be here /etc/ppp/pppoe.conf

# Linux kernel-mode plugin for pppd.  If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=rp-pppoe.so

Hopefully that will fix things for a few.
  • Like
Reactions: VictorSTS


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!