[SOLVED] Slow network Speed on VMs but not in Host


Aug 12, 2021
I have an R520 server with two Gigabit Ethernet ports running Proxmox VE 8.0. I've tested the network of the host with iperf3 and the speed is average. I have two virtual machines, the first one is running Debian 12, and the other Ubuntu 22.04. The download speed in the Vms is ok but the upload is only 25MB! I've tried to change the VM adapter to Intel E1000, Realtek RTL8139, and Vmware Vmxnet3 but the result is the same. I've also tested NUMA, Multiqueue, and other suggestions found in this forum but without success. Could anyone help me with this issue? Thanks!
Last edited:
Hello! I decided to check my connectivity and found that the problem was with my switch serving the host machine. For some reason, it was causing this slowdown only on the VMS. After changing the switch everything went back to normal.
  • Like
Reactions: _gabriel


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!