[SOLVED] Seting up second NIC / Bridge

CDman

New Member
Nov 5, 2019
2
0
1
42
Hi all,
I am new to Proxmox /coming from Vsphere/ and want to setup 2 separate Bridges on two physical NICs.

First NIC /10G Mellanox/ - vmbr0 - local LAN VMs /bridge IP 192.168.4.200/ - working fine, have 4 VMs with local IPs + its management network
Second NIC /onboard 1G Realtek/ - vmbr1 - external static IPs for VMs /188.167.212.226-229/- connecting to Hitron ISP router in bridge mode
Third NIC - future addon vmbr2, need similar config as vmbr1 - external static IPs in this bridge for VMs

My config for first bridge /Proxmox 6.09/ :

auto vmbr0
iface vmbr0 inet static
address 192.168.4.200
netmask 255.255.255.0
gateway 192.168.4.1
bridge-ports enp3s0
bridge-stp off
bridge-fd 0


I have trouble setting up second bridge /and later third/. When I setup second bridge and set static IP /188.167.212.227/ in VM on vmbr1, its internal network interface is always DOWN. There should be VMs with static IPs /I have 4 IPs from my ISP/ reachable directly from internet on vmbr1. How to configure vmbr1 IP/gateway ? I need both bridges be able to connect to internet.

Anybody can help me setup second/third NIC/bridge - like model config for vmbr1 ?

Thanks for your help and effort.

Peter
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
233
11
18

CDman

New Member
Nov 5, 2019
2
0
1
42
Hi, sorry for late reply, was busy in RL. I finaly found my stupid ERROR - syntax in interfaces config inside VMs on vmbr1 / i put "=" sign after address - like address = 188.167.212.227/.

Testing other VMs. Consider this post solved. Still learning how to work with networks on Proxmox. Will test new Nakivo 9.1 backup with native Linux server backup /using SSH/ as I could not find any reliable and also free/cheap backup solution for Proxmox VMs outside simple internal backup feature.
-----------------------------------
cat /etc/network/interfaces

auto lo
iface lo inet loopback

iface enp3s0 inet manual

iface enp6s0 inet manual

auto vmbr0
iface vmbr0 inet static
address 192.168.4.200
netmask 255.255.255.0
gateway 192.168.4.1
bridge-ports enp3s0
bridge-stp off
bridge-fd 0

auto vmbr1
iface vmbr1 inet manual
bridge-ports enp6s0
bridge-stp off
bridge-fd 0
---------

I have some VMs including Seafile file sync server running as VMs on vmbr1 bridge.
Config and IP address of VM network interface on vmbr1:

allow-hotplug ens18
auto ens18
iface ens18 inet static
address = 188.167.212.227 ---- >>> WRONG SYNTAX, should not include "="
.... etc ...

Consider this post solved. Tx for your time.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!