[SOLVED] Services not responding


New Member
Aug 30, 2023
SOLVED! - I first imaged my server offline and then connected it to my home network, I re-installed the proxmox iso while it was connected to my home network and now my services are connecting as normal

original-------My proxmox VM's that are running services like DNS or VPN are not working.
The VM creates, updates, and upgrades perfectly. They have connection to internet, I can ping to the VM and out of the VM to the router and NAS on my home network.
everything seems to work perfectly but when I connect to VPN or point my DNS to the IP of the VM running the adguard DNS server I wont have any internet.
the Adguard doesn't show any incoming queries and when connected to the PiVPN/wireguard there is no internet at all

I have set both of these services up on a raspberry pi at home so I am aware of how to set it up and confident that I did it correctly.
I have done the port forwarding on my router for wireguard as well as tried turning off the SPI firewall on my TP-Link wifi 6E router but I still get no internet with VPN.
I am at a loss as to what could be causing this block in communication on my network and makes my proxmox server just a fun toy to play with if I can't actually provide any services in the VM's I create.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!