[SOLVED] Segmentation Fault during Reboot on Proxmox - Seeking Assistance

Hawkyard

New Member
Oct 19, 2023
8
0
1
Hello everyone,

I am encountering a critical issue with my Proxmox installations and need guidance. The problem first appeared when I was trying to set up Proxmox on my server, an HPE DL380 G9. During the reboot process, I experienced a segmentation fault. The error points to line 27 in the '/sbin/unconfigured.sh' script specifically with the 'reboot -nf' command.

Here are the specifics of my situation:

  • Server Model: HPE DL380 G9
  • Proxmox Versions Tried: Proxmox VE 8.0, VE 7.4, and VE 6.4
  • Bootable USB Tool: Rufus
Each time, regardless of the Proxmox version, the same segmentation fault occurs at the same point during the reboot process. To eliminate variables, I even tried different Proxmox versions, hoping an older release might bypass this issue. Unfortunately, that wasn't the case.

Furthermore, I've been creating the bootable USBs using Rufus. However, I've read in a few discussions that some users recommend switching to Balena Etcher for creating Proxmox installation media.

Questions:

  1. Has anyone experienced a similar issue with Proxmox, particularly on the same HPE server model? If so, how was it resolved?
  2. Is it possible that Rufus is creating the bootable USB in a way that's not fully compatible with Proxmox, hence leading to this error? Would using Balena Etcher potentially circumvent this segmentation fault?
I am considering redoing the bootable USB with Balena Etcher as my next step unless there are other diagnostic recommendations or known solutions to this problem.

Any advice or insights into this matter would be immensely appreciated. Thank you in advance for your time and assistance.

Best regards
 
Hi,

During the reboot process, I experienced a segmentation fault. The error points to line 27 in the '/sbin/unconfigured.sh' script specifically with the 'reboot -nf' command.
Did Proxmox VE install successfully? Or did something fail during the installation?

If the former is the case, did you try booting into the new installation? Does everything work there?
Because, if yes, then you can just ignore it. It's harmless, just a consequence of the UI stack teardown.

I also guess that this only happens with the GUI installer (on 8.0), not with the TUI.

I've installed 8.0 on a DL380 G9 myself not that long ago, worked fine - although the ISO was inserted using iLO.
Rufus might does some weird things IIRC, Balena Etcher is just a glorified dd if=proxmox-ve.iso of=/dev/<usb>. So the latter should definitely work (if Rufus did indeed break something).
 
Hello Christoph,

Thank you for your prompt response and for sharing your insights. I appreciate your detailed guidance based on your experience with a similar server model. To provide more context, I'd like to clarify the sequence of events during my installation process:

  1. The Proxmox VE installation completes successfully without any issues.
  2. Post-installation, the system requests a reboot.
  3. I am then prompted to remove the installation USB, which I comply with.
  4. Immediately following the USB removal, instead of proceeding with a normal reboot, the system stalls. It is at this precise moment that the segmentation fault occurs, preventing any further progress. The fault necessitates a manual reboot of the system.
Despite the segmentation fault, I attempted a proactive approach by manually initiating the reboot after removing the USB, but this action didn't alter the outcome. The system does not recover on its own, nor does it complete the reboot sequence autonomously.

Given your successful interaction with the Proxmox installation using iLO, it seems increasingly likely that the methodology behind creating the bootable USB, particularly via Rufus, could be influencing this anomaly. Your explanation regarding Balena Etcher's more direct 'dd' operation sheds light on why this alternative might circumvent the issues I've encountered with Rufus.

I'm planning to create a new installation medium with Balena Etcher and embark on the installation process again. It's somewhat reassuring to consider that the segmentation fault might be a superficial glitch rather than a symptom of a more profound malfunction, especially in light of your own uneventful installation on a comparable server.

I will update this thread with the outcome after using a Balena Etcher-created USB for installation. Should this resolve the segmentation fault, it would indeed point towards the USB creation method as the culprit.

Thank you once more for your valuable input. I remain open to any additional advice or insights from the community as I work through this situation.

Best regards.
 
I attempted to use Balena Etcher to address the issue I am experiencing, but without success. Unfortunately, the error persists and occurs at the same point as before. Despite following the recommended steps and using Balena Etcher, the issue has not been resolved.

I am open to any further suggestions or guidance you might have to help resolve this problem. Thank you in advance for your assistance.

Best regards.
 
Does the hardware in question have the most recent firmware/BIOS updates applied?

Have you tried the installation from a physical DVD?
 
I've managed to solve the problem by resetting my hard drive, ty. However, now I don't have an internet connection.
 
Here are the outputs of cat /etc/network/interfaces and ip a.
 

Attachments

  • 1D641A2C-4097-4F0A-B60F-CE14E1317E73.jpg
    1D641A2C-4097-4F0A-B60F-CE14E1317E73.jpg
    446 KB · Views: 6
Oops, the photo with ip a is too large. I'll show you just the vmbr0 part. It's down. I tried to bring it up with
Code:
ip link set vmbr0 up
, but it remains down.
 

Attachments

  • 2CD749D5-CB91-4226-B903-89B5912A85F6.jpg
    2CD749D5-CB91-4226-B903-89B5912A85F6.jpg
    220.3 KB · Views: 3
I made some modifications before taking the screenshot of cat /etc/network/interfaces. I removed the 'gateways' and replaced it with 'netmask', but originally it had 'gateways'. Sorry.
 
Here are the outputs of cat /etc/network/interfaces and ip a.
There is something wrong in /etc/network/interfaces:
Kauto eno1 iface eno1 inet static
should be only:
iface eno1 inet manual.
And gateway 192.168.0.1 (or something very similar) is missing under address .
Why was this changed in such a uncommon way? See the manual for examples and more information.
Oops, the photo with ip a is too large. I'll show you just the vmbr0 part. It's down. I tried to bring it up with
Code:
ip link set vmbr0 up
, but it remains down.
I don't see the output about eno1 in the output of ip a, but maybe the problem is fixed by fixing your configuration (see above).
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!