runtime-error after fresh install (first apt-get update)

linedan

Member
Feb 8, 2020
46
1
13
26
I really tried to figure out what could be the problem here, but i give up. Maybe somebody can help me!
After a fresh install of Proxmox 5.4, i try an "apt-get update" and instand i got an runtime-error:

Linux bks003 4.15.18-12-pve #1 SMP PVE 4.15.18-35

1581155727544.png


  • the /etc/apt/source.list (i tried bove of them buster/stretch):

1581155785631.png


  • pvdisplay:
1581155984536.png


  • pveversion:
1581156036643.png
 

Attachments

  • 1581156022297.png
    1581156022297.png
    2.6 KB · Views: 1

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
498
103
Hi,
what HW does use.
It is very odd that the rdrand function does not work.
 

linedan

Member
Feb 8, 2020
46
1
13
26
Hardware:
  • HP-Server Gen9 DL380
  • 32GB RAM
  • 4TB HDD (in total)
  • Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz
It worked without Problems with the 4.4 Version of Proxmox.
But since the Upgrade we got this problem!

The rdrand-function is something like a random-generator in the intel-cpus?
 

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
498
103
rdrand is the funktion to use the random-generator in the intel-cpus or any else.
 

linedan

Member
Feb 8, 2020
46
1
13
26
OK thank you, i will try to install the kernel ith wget and then try again.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
wget http://download.proxmox.com/debian/...pve-kernel-4.15.18-9-pve_4.15.18-30_amd64.deb

dpkg -i pve-kernel-4.15.18-9-pve_4.15.18-30_amd64.deb
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 

linedan

Member
Feb 8, 2020
46
1
13
26
oh ok thank you, sorry thought this would be the solution because of the E-Mail i got!
But alright then i will try this kernel. Thank you
 

linedan

Member
Feb 8, 2020
46
1
13
26
Is the proxmox going to automatic boot from latest kernel installed if i do a:
update-grub
?
 

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
498
103
Proxmox VE will boot from the newest kernel which is installed.
the update-grub will be triggered by the kernel package installation.
 

linedan

Member
Feb 8, 2020
46
1
13
26
I took a while until i could test the new kernel, or better until i had the time to install it.
But now i installed it and restarted the server, but unfortunately "apt-get update" still not working!


dpkg --install pve-kernel-5.3.18-1-pve_5.3.18-1_amd64.deb
WORKED


After restart:

pveversion -v
proxmox-ve: 5.4-1 (running kernel: 5.3.18-1-pve)
pve-manager: 5.4-3 (running version: 5.4-3/0a6eaa62)
pve-kernel-5.3.18-1-pve: 5.3.18-1
pve-kernel-4.15: 5.3-3
pve-kernel-4.15.18-12-pve: 4.15.18-35
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-50
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-41
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-25
pve-cluster: 5.0-36
pve-container: 2.0-37
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-19
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-3
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-50
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2


Same Error:

apt-get update

Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
0% [1 InRelease gpgv 65.4 kB]terminate called after throwing an instance of 'std::runtime_error'
what(): random_device::__x86_rdrand(void)

Aborted


Any other suggestions??

 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,391
1,187
164

linedan

Member
Feb 8, 2020
46
1
13
26
I already tried both (Stretch & Buster).

#deb http://ftp.debian.org/debian buster main contrib
#deb http://ftp.debian.org/debian buster-updates main contrib
#
# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
#deb http://download.proxmox.com/debian/pve buster pve-no-subscription
#
# security updates
#deb http://security.debian.org/debian-security buster/updates main c$
#
#
# Stretch
deb http://ftp.at.debian.org/debian stretch main contrib
#
deb http://ftp.at.debian.org/debian stretch-updates main contrib
#
deb http://download.proxmox.com/debian stretch pve-no-subscription
# security updates
deb http://security.debian.org stretch/updates main contrib


So you mean if i upgrade to Proxmox-Version 6.X the apt-issue could be fixed?

Because we have 4 other HP-Servers, which are only in hardware-configuration a little bit different, and all of them work flawless.

So maybe the linux-Kernel?

Is the Upgrade to Proxmox-Version 6 possible without a complete new install?
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,391
1,187
164
mostly I wanted to point out that mixing repositories of different major relases (stretch (pve 5) and buster (pve 6) in this case) is not a good idea and can lead to quite a few problems.

Is the Upgrade to Proxmox-Version 6 possible without a complete new install?
check the wiki-page I linked - you should be able to do an in-place upgrade (but read the instructions carefully!)

i hope this helps!
 

linedan

Member
Feb 8, 2020
46
1
13
26
Ok but maybe i got the wrong view on this, but my apt doesn't work so a "in-place-upgrade" will become difficult....
So the only possibility will be a fresh install?
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,391
1,187
164
I'd first try to reboot into the latest 4.15 kernel - maybe some library interface changed, causing the apt problems for you
 

linedan

Member
Feb 8, 2020
46
1
13
26
So you also would suggest:
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
wget http://download.proxmox.com/debian/...pve-kernel-4.15.18-9-pve_4.15.18-30_amd64.deb

dpkg -i pve-kernel-4.15.18-9-pve_4.15.18-30_amd64.deb
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,391
1,187
164
please post your `pveversion -v` output - if you're running pve 5 i would expect one pve-kernel 4.15 to be installe
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!