[SOLVED] RRDC time spam

Discussion in 'Proxmox VE: Installation and configuration' started by ShinigamiLY, Jul 16, 2019.

Tags:
  1. ShinigamiLY

    ShinigamiLY New Member

    Joined:
    Jul 16, 2019
    Messages:
    3
    Likes Received:
    0
    Hey proxmox folks,

    Im new at proxmox and wanted to give it a try. Atm im still a bit frustrated cause of some stufs like the RRDC time spam.
    I know, it exists some threads about the timesync ntp and so on like this thread https://forum.proxmox.com/threads/solved-rrdc-update-error.16256/

    After a lot of trys and new installations, I werent still able to bring this message away...

    Atm I have a fresh installation of it @ Proxmox 6.0

    Message:

    Code:
    Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-node/pve: -1
    Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-storage/pve/local: -1
    Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRD update error /var/lib/rrdcached/db/pve2-storage/pve/local: /var/lib/rrdcached/db/pve2-storage/pve/local: illegal attempt to update using time 1563295303 when last update time is 1563301843 (minimum one second step)
    Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: -1
    Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRD update error /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: illegal attempt to update using time 1563295303 when last update time is 1563301843 (minimum one second step)
    
    I already tried to use another ntp, to sync it with the bios time and so on...
    I even added other ntp servers to the /etc/systemd/timesyncd.conf

    or
    hwclock --systohc --localtime
    or
    hwclock --systohc --utc

    and so on. Im prety frustrated and yes, the bios time changed after syncing but still, it exists an half seccond difference.
    Code:
    Local time: Tue 2019-07-16 18:45:53 CEST
    Universal time: Tue 2019-07-16 16:45:53 UTC
    RTC time: Tue 2019-07-16 16:45:52
    Time zone: Europe/Berlin (CEST, +0200)
    System clock synchronized: yes
    NTP service: active
    RTC in local TZ: no
    Any idea?
     
  2. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    2,551
    Likes Received:
    221
    This could happen because of BIOS settings. Is the BIOS up-to-date? Use a local time server to sync from.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ShinigamiLY

    ShinigamiLY New Member

    Joined:
    Jul 16, 2019
    Messages:
    3
    Likes Received:
    0
    I did. As u can see in my previous post, the ntp is active and the syncing works.
    I even did a sync with the bios with the command hwclock --systohc --localtime

    Anyway.
    Looks like deleting the files at
    /var/lib/rrdcached/db/pve2-storage/pve/local
    Resolved it.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice