[SOLVED] RRDC time spam

ShinigamiLY

New Member
Jul 16, 2019
7
0
1
28
Hey proxmox folks,

Im new at proxmox and wanted to give it a try. Atm im still a bit frustrated cause of some stufs like the RRDC time spam.
I know, it exists some threads about the timesync ntp and so on like this thread https://forum.proxmox.com/threads/solved-rrdc-update-error.16256/

After a lot of trys and new installations, I werent still able to bring this message away...

Atm I have a fresh installation of it @ Proxmox 6.0

Message:

Code:
Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-node/pve: -1
Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-storage/pve/local: -1
Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRD update error /var/lib/rrdcached/db/pve2-storage/pve/local: /var/lib/rrdcached/db/pve2-storage/pve/local: illegal attempt to update using time 1563295303 when last update time is 1563301843 (minimum one second step)
Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRDC update error /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: -1
Jul 16 18:41:43 pve pmxcfs[1062]: [status] notice: RRD update error /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: /var/lib/rrdcached/db/pve2-storage/pve/local-zfs: illegal attempt to update using time 1563295303 when last update time is 1563301843 (minimum one second step)
I already tried to use another ntp, to sync it with the bios time and so on...
I even added other ntp servers to the /etc/systemd/timesyncd.conf

or
hwclock --systohc --localtime
or
hwclock --systohc --utc

and so on. Im prety frustrated and yes, the bios time changed after syncing but still, it exists an half seccond difference.
Code:
Local time: Tue 2019-07-16 18:45:53 CEST
Universal time: Tue 2019-07-16 16:45:53 UTC
RTC time: Tue 2019-07-16 16:45:52
Time zone: Europe/Berlin (CEST, +0200)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no
Any idea?
 

Alwin

Proxmox Staff Member
Staff member
Aug 1, 2017
3,465
298
88
This could happen because of BIOS settings. Is the BIOS up-to-date? Use a local time server to sync from.
 

ShinigamiLY

New Member
Jul 16, 2019
7
0
1
28
I did. As u can see in my previous post, the ntp is active and the syncing works.
I even did a sync with the bios with the command hwclock --systohc --localtime

Anyway.
Looks like deleting the files at
/var/lib/rrdcached/db/pve2-storage/pve/local
Resolved it.
 

karlos

Active Member
Apr 11, 2010
46
0
26
i found this error after installing on a 2018 NUC. Updating bios, reinstalling fixed it.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!