[SOLVED] Routing between two networks over 1 physical interface not working anymore


Renowned Member
Jun 13, 2013

14 minutes ago

after a total outage of my server i recovered mostly everything. one step is missing, and i am sure it is the configuration on my hypervisor.
i am running a single server system with proxmox. in a virtual machine pfsense is doing all the stuff (simple firewalling, dhcp, dns, ...).
proxmox: 1 NIC
pfsense: 2 virtual NICs (LAN and WAN
the wan router and all devices are connected to the same switch. all requests from my LAN to WAN are forwarded to the default gateway (pfsense). pfsense forwards the to the wan-router.
hypervisor network configuration:
iface enp3s0 inet manual

auto vmbr0
iface vmbr0 inet static
bridge-ports enp3s0
bridge-stp off
bridge-fd 0

pfsense has vmx0 (LAN) and vmx1 (WAN).
it looks all fine from my perspective, but route requests to WAN are not transferred to WAN-gateway.
is the main cnfiguration right? i compared with my backup, and i can't find a difference? i tried to get it all up and running for about 12 hours now... my children are getting angry.

oh man... i guess it was a reboot that i missed after changing ipv4_forward in sysctl.conf to 1 - or just do a sysctl -p... however it works now


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!