RGmanager not running after upgrade to 2.3

netrik

Guest
Since the upgrade to 2.3, HA is not working
In the GUI it says that RGmanager is running but clustat output says otherwise

Cluster Status for netrikvm @ Thu Mar 7 22:16:50 2013
Member Status: Quorate


Member Name ID Status
------ ---- ---- ------
servm1 1 Online, Local
servm2 2 Online
sermgmt1 3 Online

I already did a 1 by 1 reboot of all 3 nodes but it stays the same

Any help would be appreciated
 

netrik

Guest
What is the output of

# fence_tool ls

root@servm1:~# fence_tool ls
fence domain
member count 3
victim count 0
victim now 0
master nodeid 2
wait state none
members 1 2 3


root@servm1:~#
 

netrik

Guest
Any hint in /var/log/cluster/rgmanager.log or /var/log/syslog?

Hi Dietmar,

I did not see anything special in syslog or rgmanager.log
I got it working again by removing my VM from the HA, making sure that they boot OK when not under HA control
Reboot my nodes 1-by-1 again with the fence_node command to make sure that fencing still works and at the same time a reboot
after reboot, added VM again to the HA

for some reason everything started working again
thx for the support, appreciate it
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!