repo refresh is too slow

abonillabeeche

New Member
Mar 4, 2019
2
0
1
41
I'm trying to install ceph with pveceph install but it looks like the repos are way too slow. Is anyone else seeing this too?

root@control:~# apt-get update

Get:1 htt.../debian stretch InRelease [8,085 B]

Err:1 htt.../debian stretch InRelease

Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)

Get:2 htt.../debian stretch-updates InRelease [8,085 B]

Err:2 htt.../debian stretch-updates InRelease

Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)

Get:3 htt... stretch/updates InRelease [8,085 B]

Err:3 htt... stretch/updates InRelease

Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)

Get:4 htt.../debian/ceph-luminous stretch InRelease [8,085 B]

Err:4 htt.../debian/ceph-luminous stretch InRelease

Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)

Ign:5 htt.../debian/pve stretch InRelease

Ign:6 htt..../debian/pve stretch Release

Ign:7 htt.../debian/pve stretch/pve-enterprise all Packages

Ign:8 htt.../debian/pve stretch/pve-enterprise amd64 Packages

Ign:9 htt.../debian/pve stretch/pve-enterprise Translation-en

Ign:10 htt.../debian/pve stretch/pve-enterprise Translation-en_US

Ign:7 htt.../debian/pve stretch/pve-enterprise all Packages

Ign:8 htt.../debian/pve stretch/pve-enterprise amd64 Packages

0% [Working]^C


and eventually, even if I leave it forever, it will error with

# pveceph install

update available package list

Reading package lists... Done

Building dependency tree

Reading state information... Done

Package ceph is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However the following packages replace it:

ceph-common


Package ceph-mds is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source


E: Package 'ceph' has no installation candidate

E: Package 'ceph-mds' has no installation candidate
 
Additionally, the UI is looking for binary not installed: /usr/bin/ceph-mon (500) but

# apt-get install ceph-common

Reading package lists... Done

Building dependency tree

Reading state information... Done

ceph-common is already the newest version (10.2.11-2).

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@control:~# /usr/bin/ceph

ceph ceph-brag ceph-crush-location ceph-fuse ceph-rbdnamer

ceph-authtool ceph-conf ceph-dencoder ceph-post-file ceph-syn
 
Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
this looks like a network/proxy error on your side

Package ceph is not available, but is referred to by another package.
probably because the system cannot properly update, see above

Additionally, the UI is looking for binary not installed: /usr/bin/ceph-mon (500) but
ceph-mon is in the package 'ceph-mon' but the package 'ceph' should be installed
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!