[SOLVED] Remove node from cluster

starnetwork

Active Member
Dec 8, 2009
413
7
38
Hi,
I have removed node from cluster before the node was shutdown
now, when I check from another node I see:
# pvecm status
Votequorum information
----------------------
Expected votes: 5
Highest expected: 5
Total votes: 4
Quorum: 3
Flags: Quorate

but I have only 4 nodes in the cluster
how can I update the
Expected votes: 5
Highest expected: 5
to 4 nodes so it's will show the real Expected and Highest Expected nodes?

Regards,
 

Chris

Proxmox Retired Staff
Retired Staff
Jan 2, 2019
598
67
28
  • Like
Reactions: Tmanok

starnetwork

Active Member
Dec 8, 2009
413
7
38
Hi,
it's already removed from the cluster
in pvecm nodes
I see only the 4 nodes
but sill
Expected votes: 5
Highest expected: 5

suggestion how can I fix it?
should I add back this server to cluster and remove it again?
another solution?

Regards,
 

Chris

Proxmox Retired Staff
Retired Staff
Jan 2, 2019
598
67
28
Try to set the value to 4 via 'pvecm expected 4'
 

Chris

Proxmox Retired Staff
Retired Staff
Jan 2, 2019
598
67
28
You still can check your nodelist in /etc/pve/corosync.conf but you should be fine
 
  • Like
Reactions: Tmanok

Chris

Proxmox Retired Staff
Retired Staff
Jan 2, 2019
598
67
28
Ah I forgot, also check the nodelist in /etc/pve/.members
 
  • Like
Reactions: Tmanok

gav

New Member
Sep 16, 2020
1
0
1
52
I have just experienced this with 6.2-11 on a two node cluster. Posting here because it appears to be highly relevant even if necro posting.

A new two node cluster for testing, removing second node from cluster as per instructions at https://pve.proxmox.com/pve-docs/pve-admin-guide.html#_remove_a_cluster_node


Code:
# pvecm nodes

Membership information
----------------------
    Nodeid      Votes Name
         1          1 test1 (local)
         2          1 test2

# pvecm delnode 2
cluster not ready - no quorum?

# pvecm expected 1
# pvecm delnode 2
error during cfs-locked 'file-corosync_conf' operation: Node/IP: 2 is not a known host of the cluster.

# pvecm nodes

Membership information
----------------------
    Nodeid      Votes Name
         1          1 test1 (local)

test2 is still present in /etc/pve/corosync.conf, /etc/pve/.members, web gui and pvesh get /nodes
 

amey

New Member
Feb 24, 2021
19
0
1
India
I am facing a strange issue.

After removing 1 node [1] from the cluster=

1) pvcmnodes = Result is OK
2) pvecm status = Result is OK

But,

If I login to web UI, it still shows server3 in the list.
How to remove it?
I don't see the entry of the removed server in = 1) /etc/pve/corosync.conf 2) /etc/pve/.members

How to fix it?
Pls suggest thank you.

Regards,
Amey.

[1] only node which was promox 7.x version, remaining 2 are on proxmox 6.3-2
 

greg

Active Member
Apr 6, 2011
120
1
38
I'm having the same problem, an old removed node is not present in the cli (`pvecm nodes` for example) but still listed in the GUI....
 
May 25, 2022
5
0
1
Hi,

Maybe you already found the answer for the GUI issue, but this worked for me.

On one of the servers still on the cluster go to the folder: /etc/pve/nodes

There you should see a folder with the name of the node you've removed from the cluster. Delete the folder and all the content in it. Then, restart corosync with: systemctl restart corosync
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!