Remove and When Proxmox Update

PVE won't do a upgrade on its own unless you manually installed some packages like "unattended-upgrades".
My guess would be that some guestOS is causing this and not the host or maybe just a backup job.
Last edited:
I still don't see the point disabling this...its a good thing to at least know when there is an update available for fixing yur servers vulnerabilities...

But if you really want to, I guess you could disable the service/timer that is triggering the update:
systemctl stop apt-daily.timer
systemctl disable apt-daily.timer
systemctl daemon-reload
systemctl start apt-daily.timer
systemctl enable apt-daily.timer
systemctl daemon-reload

Read about "systemd timers" If you want another schedule.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!