r8168 nic won't install anymore

ColinDexter

New Member
Jul 3, 2023
26
4
3
After a hard disk crash I am reinstalling proxmox. Only, I can no install my network card driver. I update the system to the latest version. I then perform the installation according to https://forum.proxmox.com/threads/system-hanging-after-upgrade-nic-driver.129366/post-581875
Everything goes well until finally I get the message below.
Code:
Error! Bad return status for module build on kernel: 6.5.11-4-pve (x86_64)
Consult /var/lib/dkms/r8168/8.051.02/build/make.log for more information.
dpkg: error processing package r8168-dkms (--configure):
 installed r8168-dkms package post-installation script subprocess returned error exit status 10
Processing triggers for libc-bin (2.36-9+deb12u3) ...
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.5.11-4-pve
Running hook script 'zz-proxmox-boot'..
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.
System booted in EFI-mode but 'grub-efi-amd64' meta-package not installed!
Install 'grub-efi-amd64' to get updates.
Errors were encountered while processing:
 r8168-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
If I then restart the system, the network card no longer works. And with lsmod|grep 816 there is no network driver anymore

Who can tell me why this no longer works? I installed this a few months ago and it worked without any problems
 

Attachments

  • make.log
    1.4 KB · Views: 1
Looks like your driver is not compatible with the kernel version you are running. Maybe get an updated r8168 driver that does work with 6.5.11 from where you got your current driver? Or install/boot an older version of the kernel like 6.2, which was used with Proxmox 8.0 and can still be installed.
 
I also get the same error message with Proxmox 8.0 installed :-(
/var/lib/dkms/r8168/8.051.02/build/r8168_n.c: In function ‘r8168_csum_workaround’: /var/lib/dkms/r8168/8.051.02/build/r8168_n.c:29208:24: error: implicit declaration of function ‘skb_gso_segment’; did you mean ‘skb_gso_reset’? [-Werror=implicit-function-declaration] 29208 | segs = skb_gso_segment(skb, features); | ^~~~~~~~~~~~~~~ | skb_gso_reset /var/lib/dkms/r8168/8.051.02/build/r8168_n.c:29208:22: warning: assignment to ‘struct sk_buff *’ from ‘int’ makes pointer from integer without a cast [-Wint-conversion] 29208 | segs = skb_gso_segment(skb, features); | ^
If you still get these errors with kernel 6.2 then it's also not compatible with that kernel version. Maybe the people that provide this driver can help you figure out which kernel versions are compatible?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!