Query: LXC Fails to start at boot / despite auto-start setting / starts fine by manual intervention after.

fortechitsolutions

Well-Known Member
Jun 4, 2008
393
38
48
Hi, I am curious if anyone has seen this sort of behaviour before?

I have a proxmox host I setup a few months ago. Runs nicely, it seems. There was a hurricane/power outage this past weekend.

Proxmox rebooted cleanly, and one of two VMs on the host auto-started correctly at boot.

The one which failed to start. Appears to be related to error message:

EXT4-fs warning (device loop2): ext4_multi_mount_protect:325: MMP interval 42 higher than expected, please wait.

This is for proxmox version:
(output of pveversion): pve-manager/5.4-10/9603c337 (running kernel: 4.15.18-17-pve)


I was able to SSH into the proxmox host and then start the VM manually via CLI, simply via 'pct start 100' command, no other effort required.

I am a bit baffled, why I can start it so easliy, but it fails to auto-start at boot / and throws this error.

I did a bit of google digging and fine a few hits, but not seem quite relevant here.

I do have an extra piece of disk mounted, but it is not identified internally as loop2. Rather inside the VM we have loop0 and loop1, as per:

root@r-studio:/var/log# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/loop0 492G 373G 94G 80% /
/dev/loop1 8.8T 670G 7.7T 8% /data
none 492K 0 492K 0% /dev
udev 32G 0 32G 0% /dev/tty
tmpfs 32G 0 32G 0% /dev/shm
tmpfs 32G 8.1M 32G 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 32G 0 32G 0% /sys/fs/cgroup
root@r-studio:/var/log#

and my VM config for this is,
root@proxmox:/etc/pve/lxc# more 100.conf
## misc notes here
arch: amd64
cores: 16
hostname: rbox
memory: 61440
mp0: bcache-9tb:100/vm-100-disk-0.raw,mp=/data,size=9000G
net0: name=eth0,bridge=vmbr0,firewall=1,gw=192.168.0.254,hwaddr=CA:22:1D:86:39:59,ip=192.168.0.251/24,type=veth
onboot: 1
ostype: debian
rootfs: local:100/vm-100-disk-0.raw,size=500G
swap: 0
unprivileged: 1

root@proxmox:/etc/pve/lxc#



If anyone has any thoughts / suggestions / comments - any ideas are most welcome / appreciated.

Thanks!

Tim
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
695
118
hi,

EXT4-fs warning (device loop2): ext4_multi_mount_protect:325: MMP interval 42 higher than expected, please wait.

it sounds like the disk that the container is trying to mount may be in use at boot time.
I was able to SSH into the proxmox host and then start the VM manually via CLI, simply via 'pct start 100' command, no other effort required.

maybe you could try setting a startup delay and see if that works
 

Ventzy

Member
Oct 16, 2013
7
0
21
I had similar experience - ext4_multi_mount_protect error and some of the containers couldn't start. What fixed the problem was running filesystem check on each container with
pct fsck 100
 

maenda

Member
Jul 10, 2020
26
0
6
47
I had similar experience - ext4_multi_mount_protect error and some of the containers couldn't start. What fixed the problem was running filesystem check on each container with

This works indeed, but after a reboot of the ct same issue is back and need a fsck again.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!