[SOLVED] qm start hangs after update to 5.4


New Member
Jun 5, 2019

I have a single node which was running a couple of VM's without any issues for last 6 months (version (5.1.XX)). Today I've updated the node to the latest version - 5.4 (using apt-get update && apt-get dist-upgrade) and since then I cannot get any of my Windows VMs to start. Though linux based VMs - Ubuntu - start without issues.
The windows VMs have GPU and USB passthrough set.

When I run qm start <VMID>, the process hangs indefinitely and if I query the VM status, it always reports stopped. Can someone help me identifying the cause of this issue? Thanks!

Here is my pveversion -v output:

proxmox-ve: 5.4-1 (running kernel: 4.15.18-15-pve)
pve-manager: 5.4-6 (running version: 5.4-6/aa7856c5)
pve-kernel-4.15: 5.4-3
pve-kernel-4.15.18-15-pve: 4.15.18-40
pve-kernel-4.13.13-5-pve: 4.13.13-38
pve-kernel-4.13.13-2-pve: 4.13.13-33
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-10
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-52
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-43
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-37
pve-container: 2.0-39
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-2
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-52
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2

and here is a VM config of a Windows machine:
agent: 1
bootdisk: scsi0
cores: 8
cpu: host
hostpci0: 81:00.0,pcie=1,x-vga=on
hostpci1: 00:1b.0
machine: q35
memory: 12960
name: dev01win10
net0: virtio=0E:95:4E:18:2D:36,bridge=vmbr0
numa: 0
onboot: 1
ostype: win10
scsi0: local-zfs:vm-100-disk-1,backup=0,discard=on,replicate=0,size=100G
scsi1: share:vm-100-disk-1,discard=on,size=150G
scsihw: virtio-scsi-pci
smbios1: uuid=ea24dbb8-148c-4ee2-aff7-4f11fd27ac8c
sockets: 2
usb0: host=1-1.5.1
usb1: host=1-1.5.2
usb2: host=1-1.5.3
usb3: host=1-1.5.4
usb4: host=1-1.1


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!