qm list lässt sich nicht beenden

BigBen

Active Member
Jun 18, 2015
134
4
38
Germany
$ pveversion -v
proxmox-ve: 6.1-2 (running kernel: 5.3.10-1-pve)
pve-manager: 6.1-3 (running version: 6.1-3/37248ce6)
pve-kernel-5.3: 6.0-12
pve-kernel-helper: 6.0-12
pve-kernel-5.0: 6.0-11
pve-kernel-4.15: 5.4-9
pve-kernel-5.3.10-1-pve: 5.3.10-1
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.21-3-pve: 5.0.21-7
pve-kernel-5.0.21-2-pve: 5.0.21-7
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-12-pve: 4.15.18-36
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.1-2
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.1-2
pve-container: 3.0-14
pve-docs: 6.1-3
pve-edk2-firmware: 2.20191002-1
pve-firewall: 4.0-9
pve-firmware: 3.0-4
pve-ha-manager: 3.0-8
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-2
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2

Hallo,

seit dem letzten Upgrade treten merkwürdige Verhaltensweisen auf:

Befehle werden im Terminal-Fenster nicht beendet. Aufgefallen ist mir das bei der Ausführung von "qm list".

Die Prozesse sind auch nach mehreren Stunden noch aktiv.

$ ps aux | grep 'qm list' | grep -v grep
root 4627 0.0 0.3 325304 111296 pts/25 D 17:02 0:00 /usr/bin/perl /usr/sbin/qm list
root 8988 0.0 0.3 325264 111272 ? D 09:35 0:00 /usr/bin/perl /usr/sbin/qm list
root 27224 0.0 0.3 325176 111448 ? D 09:30 0:00 /usr/bin/perl /usr/sbin/qm list
root 28340 0.0 0.3 325256 111252 ? D 17:00 0:00 /usr/bin/perl /usr/sbin/qm list

Selbst das Killen der einzelnen Prozesse schlägt ebenfalls fehl:

$ kill 28340 27224 8988 4627

Nach der Ausführung werden die Prozesse weiterhin gelistet:

$ ps aux | grep 'qm list' | grep -v grep
root 4627 0.0 0.3 325304 111296 pts/25 D 17:02 0:00 /usr/bin/perl /usr/sbin/qm list
root 8988 0.0 0.3 325264 111272 ? D 09:35 0:00 /usr/bin/perl /usr/sbin/qm list
root 27224 0.0 0.3 325176 111448 ? D 09:30 0:00 /usr/bin/perl /usr/sbin/qm list
root 28340 0.0 0.3 325256 111252 ? D 17:00 0:00 /usr/bin/perl /usr/sbin/qm list

Zur Info: Nach dem Upgrade wurde das Proxmox-System normal neu gebootet.

Ansonsten sind keine Auffälligkeiten festgestellt worden.

Kann jemand helfen, die Fehlerursache einzugrenzen?

Nachtrag:

Auch der Befehl zum Starten von VMs wird nicht ausgeführt:

$ qm start 108
timeout waiting on systemd

Hier sollte das System mit der ID 108 gestartet werden.

Zur Info: pvestatd läuft:

$ systemctl status pvestatd
● pvestatd.service - PVE Status Daemon
Loaded: loaded (/lib/systemd/system/pvestatd.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2019-12-16 12:42:09 CET; 1 day 4h ago
Process: 6272 ExecStart=/usr/bin/pvestatd start (code=exited, status=0/SUCCESS)
Main PID: 6279 (pvestatd)
Tasks: 1 (limit: 4915)
Memory: 124.5M
CGroup: /system.slice/pvestatd.service
└─6279 pvestatd

Dec 16 12:47:50 pve pvestatd[6279]: modified cpu set for lxc/114: 0,5
Dec 16 12:47:50 pve pvestatd[6279]: modified cpu set for lxc/115: 1,3
Dec 16 12:47:50 pve pvestatd[6279]: modified cpu set for lxc/116: 7
Dec 16 12:48:01 pve pvestatd[6279]: modified cpu set for lxc/130: 1,4
Dec 16 14:21:49 pve pvestatd[6279]: modified cpu set for lxc/115: 3,5
Dec 16 15:40:29 pve pvestatd[6279]: modified cpu set for lxc/102: 1,3,7
Dec 16 17:13:59 pve pvestatd[6279]: modified cpu set for lxc/102: 1,5,7
Dec 16 17:17:39 pve pvestatd[6279]: modified cpu set for lxc/102: 3,5,7
Dec 16 17:17:49 pve pvestatd[6279]: modified cpu set for lxc/106: 0,2
Dec 16 17:39:40 pve pvestatd[6279]: auth key pair too old, rotating..

-----

Es scheint so, als wenn ein System-Reboot nicht mehr durchgeführt werden kann.

Zumindest ist der Button "Reboot" im Web-Oberfläche wirkungslos.

Auch ein Reboot Befehl im Terminal wird ebenfalls nicht mehr ausgeführt.

Wer weiß denn, wie die verantwortliche Arbeitseinheit erreicht werden kann, die das letzte Upgrade freigegeben hat. Ich lasse mich nicht gerne als Beta-Tester missbrauchen.

Das System konnte nur durch ein Hardware-Reset Neu gebootet werden.
Beim Booten ist mir folgende Meldung aufgefallen:
proxmox Boot Meldung.png
Vielleicht kann damit jemand etwas anfangen?

Bei der Durchsicht von einigen LXC- und VM-Systemen ist mir aufgefallen, dass diese seit mindestens 12 Stunden nicht mehr gelaufen sind. Es scheint so, als wenn alle virtuelle Systeme irgendwann gestoppt worden sind.

Fehlverhalten dieser Art sind mir bei den letzten Upgrades noch nicht untergekommen.
 
Last edited:

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,145
543
143
Austria
www.proxmox.com
Verwendest Du NFS oder einen anderen Network storage? Wenn ja, dann überprüfe bitte dass diese online sind und funktionieren.

Das Verhalten das Du beschreibst wird meisten von einen hängendem Storage verursacht...
 

BigBen

Active Member
Jun 18, 2015
134
4
38
Germany
NFS wird verwendet. Es sind alle Quellen online verfügbar. Da Antwort-Verhalten des NFS ist auch normal. Es gibt keine Verzögerungen beim Zugriff.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!