QEMU[817526]: kvm: virtio: zero sized buffers are not allowed on 7.4-15


Oct 15, 2019
Hello Everyone,

We are seeing an issue where VMs freeze/crash as it looks like the storage drops out. We have a mix of remote Ceph RBD and ZFS single disk local pools with encryption turned on. The issue seems pretty isolated to SQL 2019 AAG on Windows 2019. The OS disk is on Ceph while the databases are on ZFS.

We have tried a few different versions of qemu tools. We run virtio single, iothreads, native, discard but have tried turning discard off as well.

VM CPU is set to Host, which are 2nd Gen EPYC.

Would appreciate any workaround or solutions if they exist.



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!