[SOLVED] [pveupgrade] error processing kernel

Spoonman2002

Active Member
Jul 6, 2021
348
27
33
52
Holland
Hi,

I just ran into this error when doing a "pveupdate" and "pveupgrade" on my PVE host.
I'm running kernel 6.2 for a few weeks now, before that I had kernel 5.15.
No problems no errors, until now.
What is the solution, I tried apt autoremove, apt full-upgrade, apt dist-upgrade. Still these errors :

Starting system upgrade: apt-get dist-upgrade Reading package lists... Done Building dependency tree... Done Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 3 not fully installed or removed. Need to get 0 B/76.8 MB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] Y Setting up pve-kernel-5.15.108-1-pve (5.15.108-1) ... Examining /etc/kernel/postinst.d. run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 5.15.108-1-pve /boot/vmlinuz-5.15.108-1-pve run-parts: executing /etc/kernel/postinst.d/initramfs-tools 5.15.108-1-pve /boot/vmlinuz-5.15.108-1-pve update-initramfs: Generating /boot/initrd.img-5.15.108-1-pve Running hook script 'zz-proxmox-boot'.. Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace.. Copying and configuring kernels on /dev/disk/by-uuid/0E8B-8012 Copying kernel and creating boot-entry for 5.15.108-1-pve Copying kernel and creating boot-entry for 6.2.11-1-pve Copying kernel and creating boot-entry for 6.2.11-2-pve run-parts: executing /etc/kernel/postinst.d/proxmox-auto-removal 5.15.108-1-pve /boot/vmlinuz-5.15.108-1-pve run-parts: executing /etc/kernel/postinst.d/zz-proxmox-boot 5.15.108-1-pve /boot/vmlinuz-5.15.108-1-pve Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace.. Copying and configuring kernels on /dev/disk/by-uuid/0E8B-8012 Copying kernel and creating boot-entry for 5.15.108-1-pve Copying kernel and creating boot-entry for 6.2.11-1-pve Copying kernel and creating boot-entry for 6.2.11-2-pve run-parts: executing /etc/kernel/postinst.d/zz-update-grub 5.15.108-1-pve /boot/vmlinuz-5.15.108-1-pve /usr/sbin/grub-mkconfig: 1: /etc/default/grub: Proxmox: not found run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/pve-kernel-5.15.108-1-pve.postinst line 19. dpkg: error processing package pve-kernel-5.15.108-1-pve (--configure): installed pve-kernel-5.15.108-1-pve package post-installation script subprocess returned error exit status 2 dpkg: dependency problems prevent configuration of pve-kernel-5.15: pve-kernel-5.15 depends on pve-kernel-5.15.108-1-pve; however: Package pve-kernel-5.15.108-1-pve is not configured yet. dpkg: error processing package pve-kernel-5.15 (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: pve-kernel-5.15.108-1-pve pve-kernel-5.15 E: Sub-process /usr/bin/dpkg returned an error code (1) Your System is up-to-date
 
what is the content ? (cat /etc/default/grub)

# If you change this file, run 'update-grub' afterwards to update # /boot/grub/grub.cfg. # For full documentation of the options in this file, see: # info -f grub -n 'Simple configuration' GRUB_DEFAULT=0 GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR=`Proxmox Virtual Environment` GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt" GRUB_CMDLINE_LINUX="" # Uncomment to enable BadRAM filtering, modify to suit your needs # This works with Linux (no patch required) and with any kernel that obtains # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...) #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef" # Uncomment to disable graphical terminal (grub-pc only) #GRUB_TERMINAL=console # The resolution used on graphical terminal # note that you can use only modes which your graphic card supports via VBE # you can see them in real GRUB with the command `vbeinfo' #GRUB_GFXMODE=640x480 # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux #GRUB_DISABLE_LINUX_UUID=true # Uncomment to disable generation of recovery mode menu entries GRUB_DISABLE_RECOVERY="true" # Uncomment to get a beep at grub start #GRUB_INIT_TUNE="480 440 1"
 
Code:
GRUB_DISTRIBUTOR=`Proxmox Virtual Environment`

Seem wrong, it should be double quoted

Code:
GRUB_DISTRIBUTOR="Proxmox Virtual Environment"

(It's like this on all my proxmox install, not sure why you have single quote here)

THANK YOU SOOOO MUCH!!!
That was indeed the solution, double quote marks.
No clue how those single quotes got there...
And this had been running for months.
Anyway, I'm very happy now!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!