pve7to8 giving false error on pveversion?

Pyromancer

Member
Jan 25, 2021
24
6
8
47
Trying to follow the upgrade process, and the pve7to8 check script, even after a restart, throws this error: "proxmox-ve package is too old, please upgrade to >= 7.4-1!"

Which doesn't make a great deal of sense when:
root@covenstead:~# pveversion pve-manager/7.4-15/a5d2a31e (running kernel: 5.15.108-1-pve)

Detailed process:
I was on 7.2-5, so did
apt update apt upgrade

That raised the version reported on the GUI to 7.4-15 without even needing a reboot. To be on the safe side I then did shutdown -r now before proceeding. But even so, pve7to8 gives the error above.

Can I safely assume this is just a bug in the check script, and carry on with the upgrade regardless?
 
apt upgrade
Please always use apt full-upgrade or apt-get dist-upgrade. It is possible that some dependencies were not installed. Run one of the two commands. There are most likely packages that need to be installed or removed and run the check again.
 
  • Like
Reactions: Pyromancer
Please always use apt full-upgrade or apt-get dist-upgrade. It is possible that some dependencies were not installed. Run one of the two commands. There are most likely packages that need to be installed or removed and run the check again.
Thank you!

That's cured the error.

Noted for future use.
 
  • Like
Reactions: prcek and aaron

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!