PVE-ZYNC issue with space?

killmasta93

Renowned Member
Aug 13, 2017
956
56
68
30
Hi,
i was wondering if someone could help me understand something odd about PVE-ZYNC recently have a few vms working great with PVE-ZYNC but i have a vm that i want to use pve-zync but i saw that as soon i ran pve-zync the storage spiked around 300 gigs which does not make sense.

The vm is 102 the dump files make 300gigs
Code:
102    ServidorBD    OK    04:07:46    307.79GB

on the zfs list i get this
Code:
vmdata15k/vm-102-disk-0     954G   626G   335G  -
vmdata15k/vm-102-disk-1    82.5G  25.8G  64.0G  -
vmdata15k/vm-102-disk-2    33.0G  12.8G  27.6G  -

but when i ran the pve-zsync it says 500gigs (see picture) but what i dont get why the snapshot so big the rest of the vms did not have that issue

after eventually i get this error
Code:
19:36:22    507G   vmdata15k/vm-102-disk-0@rep_bd_2019-09-08_18:07:32
WARN: COMMAND:
        zfs destroy vmdata15k/vm-102-disk-1@rep_bd_2019-09-08_18:07:32
GET ERROR:
        could not find any snapshots to destroy; check snapshot names.
WARN: COMMAND:
        ssh root@192.168.3.199 -- zfs destroy rpool/data/vm-102-disk-1@rep_bd_2019-09-08_18:07:32
GET ERROR:
        cannot open 'rpool/data/vm-102-disk-1': dataset does not exist
Job --source 102 --name bd got an ERROR!!!
ERROR Message:
COMMAND:
        zfs snapshot vmdata15k/vm-102-disk-1@rep_bd_2019-09-08_18:07:32
GET ERROR:
        cannot create snapshot 'vmdata15k/vm-102-disk-1@rep_bd_2019-09-08_18:07:32': out of space

Thank you
 

Attachments

  • Screenshot from 2019-09-08 18-13-37.png
    Screenshot from 2019-09-08 18-13-37.png
    103.9 KB · Views: 6
  • Screenshot from 2019-09-08 18-16-36.png
    Screenshot from 2019-09-08 18-16-36.png
    26 KB · Views: 6
Last edited:
Do you have compression enabled on the source pool but not the target pool?
 
Thanks for the reply attaching you the files both pools have compression
Code:
root@prometheus3:~# zfs get all | grep compressratio
vmdata15k                                                compressratio         1.41x                  -
vmdata15k                                                refcompressratio      1.00x                  -
vmdata15k/vm-102-disk-0                                  compressratio         1.48x                  -
vmdata15k/vm-102-disk-0                                  refcompressratio      1.48x                  -
vmdata15k/vm-102-disk-1                                  compressratio         1.21x                  -
vmdata15k/vm-102-disk-1                                  refcompressratio      1.21x                  -
vmdata15k/vm-102-disk-2                                  compressratio         1.11x                  -
vmdata15k/vm-102-disk-2                                  refcompressratio      1.11x                  -



Code:
rpool/data                                                  type                  filesystem             -
rpool/data                                                  creation              Sat Aug 24 14:22 2019  -
rpool/data                                                  used                  88.2G                  -
rpool/data                                                  available             1.38T                  -
rpool/data                                                  referenced            96K                    -
rpool/data                                                  compressratio         1.45x                  -
rpool/data                                                  mounted               yes                    -
rpool/data                                                  quota                 none                   default
rpool/data                                                  reservation           none                   default
rpool/data                                                  recordsize            128K                   default
rpool/data                                                  mountpoint            /rpool/data            default
rpool/data                                                  sharenfs              off                    default
rpool/data                                                  checksum              on                     default
rpool/data                                                  compression           on                     inherited from rpool
rpool/data                                                  atime                 off                    inherited from rpool
rpool/data                                                  devices               on                     default
rpool/data                                                  exec                  on                     default
rpool/data                                                  setuid                on                     default
rpool/data                                                  readonly              off                    default
rpool/data                                                  zoned                 off                    default
rpool/data                                                  snapdir               hidden                 default
rpool/data                                                  aclinherit            restricted             default
rpool/data                                                  createtxg             8                      -
rpool/data                                                  canmount              on                     default
rpool/data                                                  xattr                 on                     default
rpool/data                                                  copies                1                      default
rpool/data                                                  version               5                      -
rpool/data                                                  utf8only              off                    -
rpool/data                                                  normalization         none                   -
rpool/data                                                  casesensitivity       sensitive              -
rpool/data                                                  vscan                 off                    default
rpool/data                                                  nbmand                off                    default
rpool/data                                                  sharesmb              off                    default
rpool/data                                                  refquota              none                   default
rpool/data                                                  refreservation        none                   default
rpool/data                                                  guid                  2623610019628968711    -
rpool/data                                                  primarycache          all                    default
rpool/data                                                  secondarycache        all                    default
rpool/data                                                  usedbysnapshots       0B                     -
rpool/data                                                  usedbydataset         96K                    -
rpool/data                                                  usedbychildren        88.2G                  -
rpool/data                                                  usedbyrefreservation  0B                     -
rpool/data                                                  logbias               latency                default
rpool/data                                                  dedup                 off                    default
rpool/data                                                  mlslabel              none                   default
rpool/data                                                  sync                  disabled               inherited from rpool
rpool/data                                                  dnodesize             legacy                 default
rpool/data                                                  refcompressratio      1.00x                  -
rpool/data                                                  written               96K                    -
rpool/data                                                  logicalused           127G                   -
rpool/data                                                  logicalreferenced     40K                    -
rpool/data                                                  volmode               default                default
rpool/data                                                  filesystem_limit      none                   default
rpool/data                                                  snapshot_limit        none                   default
rpool/data                                                  filesystem_count      none                   default
rpool/data                                                  snapshot_count        none                   default
rpool/data                                                  snapdev               hidden                 default
rpool/data                                                  acltype               off                    default
rpool/data                                                  context               none                   default
rpool/data                                                  fscontext             none                   default
rpool/data                                                  defcontext            none                   default
rpool/data                                                  rootcontext           none                   default
rpool/data                                                  relatime              off                    default
rpool/data                                                  redundant_metadata    all                    default
rpool/data                                                  overlay               off                    default
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!