[SOLVED] PVE 8.0 Kernel crashes on Hetzner server


Renowned Member
Hi everyone,

I just ordered a new AX41 server at Hetzner and tried to install PVE 8.0.
Base is Debian 12 Bookworm, I use the installation from https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_12_Bookworm. At least I try to...

pve-kernel-6.2 hangs on boot. I gave pve-kernel-6.1 a try, the same.

I analysed kernel boot messages and compared it with the messages from Debian kernel 6.1.0-9-amd64 which is the default after installation. From pve-kernel I see the following message (last message):
Jun 27 10:23:56 pve kernel: divide error: 0000 [#1] PREEMPT SMP NOPTI
Jun 27 10:23:56 pve kernel: CPU: 11 PID: 414 Comm: (udev-worker) Not tainted 6.2.16-3-pve #1
Jun 27 10:23:56 pve kernel: Hardware name: Hetzner /B450 Pro4 R2.0, BIOS H8.02C 05/15/2023
Jun 27 10:23:56 pve kernel: RIP: 0010:nvGetClocks+0x1bd/0x300 [nvidiafb]
Jun 27 10:23:56 pve kernel: Code: 0f 84 a6 00 00 00 3d 30 03 00 00 0f 84 9b 00 00 00 8b 8a 04 05 00 00 0f b6 c5 31 d2 41 0f af c1 44 0f b6 c9 c1 e9 10 83 e1 0f <41> f7 f1 d3 e8 41 89 00 48 8b 87 88 11 00 00 8b 88 00 05 00 00 0f
Followed by a stack trace.

Do you have any hints, what's going on?
Are there workarounds like disabling same hardware/drivers?
Might this issue be triggered by a BIOS bug?

Does anybody run PVE 8.0 successfully on Hetzner AX41?

Thanks for your help.
Did not work for me using the old Kernel. My AX41 still won't boot after installing Proxmox kernel.
Did you block the nvidia driver as I indicated in my post? It's necessary.
The other way is to ignore the Proxmox Kernel and go with Debian Kernel.

My config as documented in my own wiki:
echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf echo blacklist nvidiafb > /etc/modprobe.d/blacklist-nvidiafb.conf # update initramfs (use correct kernel version) update-initramfs -u -k 6.2.16-3-pve
First, I followed the Proxmox Wiki instructions:
echo "deb [arch=amd64] http://download.proxmox.com/debian/pve bullseye pve-no-subscription" > /etc/apt/sources.list.d/pve-install-repo.list
wget https://enterprise.proxmox.com/debian/proxmox-release-bullseye.gpg -O /etc/apt/trusted.gpg.d/proxmox-release-bullseye.gpg
apt update && apt full-upgrade
apt install pve-kernel-5.15
Then, I followed the instructions from the blog post:
sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf
blacklist nouveau
options nouveau modeset=0

sudo update-initramfs -u
(Before installing pve-kernel-5.15 I did a reboot, which worked fine.)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!