PVE 5 Windows guest VM slow to start

cot

Member
Aug 24, 2015
33
0
6
Hello,

I'm running PVE 4 and PVE 5. I noticed 'Windows server 2012 R2' VM on PVE 5 are slower to start than on PVE 4. Anyone experiencing this problem?

I'm using templates VM migrated from PVE 4 to PVE 5. It's fast to boot on PVE 4 but really slow to boot on PVE 5.
 
Last edited:

cot

Member
Aug 24, 2015
33
0
6
Now I suspect default memory ballooning checkbox that was introduced in v4.4 that may the cause of this issue.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,775
343
83
31
Vienna
Now I suspect default memory ballooning checkbox that was introduced in v4.4 that may the cause of this issue.
i cannot imagine how, since the default settings stayed the same (only an additional settings got exposed)

but there was another thread with similar symptoms, afair the solution was to install the ballooning service and driver
 

cot

Member
Aug 24, 2015
33
0
6
Hi Dominik,

Would unchecking ballooning in v5 the same as pre-v4.4 "use fixed sized memory" option?
 

cot

Member
Aug 24, 2015
33
0
6
I think I may have resolved the slow boot up issue by 'unchecking' the default balloon option in memory setting.
It seemed the boot up is much faster without ballooning.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,775
343
83
31
Vienna
Would unchecking ballooning in v5 the same as pre-v4.4 "use fixed sized memory" option?
hi, no the default (checked balloon and min memory equals max memory) is the same as in v4, we simply changed how we presented it

I think I may have resolved the slow boot up issue by 'unchecking' the default balloon option in memory setting.
It seemed the boot up is much faster without ballooning.
great that you found a solution, but did you also try to install the balloon service as well as the driver like i mentioned?
 

cot

Member
Aug 24, 2015
33
0
6
hi, no the default (checked balloon and min memory equals max memory) is the same as in v4, we simply changed how we presented it


great that you found a solution, but did you also try to install the balloon service as well as the driver like i mentioned?
Yes, I've installed balloon service and memory usage is very much lower and accurately reported on host that matches memory usage on Windows OS performance monitor. VM startup is also much faster due to more memory available to the host now.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!