[pve 5.4.5] pvesh migrate minor bug "garbage after JSON-Object"


New Member
Mar 19, 2019
When I migrate a vm from command line - initiated at the host where the vm resides - all is fine:
THISNODE# pvesh create /nodes/THISNODE/qemu/106/migrate -target=OTHERNODE -online
starting migration...
migration finished successfully

When I migrate a vm from command line from a remote node to the current node, I get an error:
THISNODE# pvesh create /nodes/OTHERNODE/qemu/106/migrate -target=THISNODE -online
garbage after JSON object, at character offset 4 (before "-05-14 12:40:14 star...") at /usr/share/perl5/PVE/CLI/pvesh.pm line 125.

The migration worked in both cases. It's only that the cli exits with an error, so I can not determine from a script if the migration worked well.

oops. I wrote in the wrong language. Please move the thread to the correct forum.
Last edited:
I think this was fixed recently by this patch. It should work with the new (i.e. 6.1-8) pve-manager package. Please try it out.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!