Proxmox won't start with networking

jdw

Renowned Member
Sep 22, 2011
118
4
83
I have one Proxmox VE server that hangs on boot. With "quiet" disabled, it hangs at "Job networking.service/start running (7min 30s / no limit)."

If I move /etc/network/interfaces to /etc/network/interfaces.no, the machine will boot up.

If I then log in to the machine and rename the file back to /etc/network/interfaces, I can do "systemctl restart networking" and that will complete fine with all networking working correctly. (Three interfaces, one bond of two interfaces, two vmbr's, and two VLANs.)

So, that has me a little baffled. I'm guessing it must be hanging on something else started as part of that service, but I don't know how to figure out what.

I've tried commenting out pretty much the whole interfaces file. It boots with this:

Code:
auto lo
iface lo inet loopback

but hangs with this:

Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet static
    address 192.168.103.33/24
    gateway 192.168.103.254

So I don't think it's the actual interfaces. I'm just unsure what else happens or how to find out what's wrong with it. I've tried booting in single-user mode and running "systemctl start networking" (which hangs) with LogLevel=debug in /etc/systemd/system.conf. I don't see anything useful in the logs.

The functionally identical (except for IPs) full config boots fine on the machine right next to it.

I'm lost. I haven't experienced anything like this before.

Does anyone have any idea what it might be?

If I can't figure this out, I'll probably try reinstalling it to see if that helps.

Thanks for any advice!
 
Turns out we have two of these. I thought I had fixed the other one before this one ever came up, but it got rebooted today and did the same thing. (Probably what happened is I did "systemctl restart networking" after moving the file back and left it like that figuring it must be fixed.)

Four other Proxmox servers also rebooted today, and they're all fine.
 
Last edited:
Did you find the cause of this yet? I have the same problem with one of our servers going from proxmox 7 to proxmox 8. Still can't find what is causing the hang.
 
No, I sure didn't. But the affected servers were also upgraded from 7 to 8. (Not clean installs.) Perhaps that is relevant.
 
I found out it was because i had ntpdate & ntp installed both (see release notes about this). Didn´t read the manual well enough.
 
Looks like that's it for us as well. Somehow, ntpdate slipped onto the two affected systems.

Thank you for the pointer!
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!