Proxmox wont start after working GPU passthrow


New Member
Aug 26, 2023
So, I managed to get a VM working with GPU passthrough. Initially, I was just testing it on my server, but I eventually decided to use it as my main server host. During this process, I had to open the computer to install some additional cards, including an Ethernet card. However, while doing this, I accidentally hit the CMOS button. As a result, Proxmox now refuses to start. The system does boot when the PCI graphics card is removed.

The machine I'm using is an HP Elitedesk 800 G1 with 32GB of RAM.

I need to access the BIOS settings and disable the PCI graphics card. Unfortunately, I can't enter the BIOS with the PCI card installed. Moreover, with or without the card, the VGA settings in BIOS are grayed out.

Strangely, I've managed to boot into Windows. Within Windows, I've noticed a resource conflict with the PCI bus. I didn't anticipate that any of the GRUB settings would impact the motherboard in this way.

I'm wondering if there's a way to reset the PCI address or resolve the resource conflict.

For reference, here are the commands I used to set up GPU passthrough:

  1. Opened the GRUB configuration:
    arduinoCopy code
    nano /etc/default/grub
  2. Modified the GRUB default command line:
    makefileCopy code
    GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"
  3. Updated GRUB:
    sqlCopy code
  4. Edited the modules configuration:
    bashCopy code
    nano /etc/modules
  5. Added options for unsafe interrupts:
    bashCopy code
    echo "options vfio_iommu_type1 allow_unsafe_interrupts=1" > /etc/modprobe.d/iommu_unsafe_interrupts.conf
  6. Modified the blacklist configuration:
    bashCopy code
    nano /etc/modprobe.d/blacklist.conf
    Added the following lines:
    Copy code
    blacklist radeon
    blacklist nouveau
    blacklist nvidia
  7. Unbound the GPU from its current driver:
    rubyCopy code
    echo "0000:01:00.0" > /sys/bus/pci/drivers/vfio-pci/unbind
  8. Bound the GPU to the vfio-pci driver:
    rubyCopy code
    echo "0000:01:00.0" > /sys/bus/pci/drivers/vfio-pci/bind

    I might have done something more...
I'd greatly appreciate any advice or solutions to the current issue. Thank you in advance for your assistance!
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!