[SOLVED] Proxmox wont boot after power failure: (Time out waiting for device)


New Member
Aug 17, 2023
Hi all,
I'm a real n00b so please bear with me.

My machine running Proxmox got unintentionally turned off after a power failure and now it won't boot beyond the emergency mode screen:
(apologies for sharing images as I'm not sure how else to share the screen from this menu):

The drive in question is an SSD thats inside the machine, labelled storage (sda). It's got no valuable data on it.

MicrosoftTeams-image (2).jpg

Output of lsblk:
MicrosoftTeams-image (6).jpg

Output of fdisk -l:
MicrosoftTeams-image (5).jpg

I have tried searching for a solution to this but with no luck.
Is anyone able to kindly assist?
Last edited:
And for the future...if you care about your data and you don't want to corrupt your filesystems on a power outage, get a UPS so your server can do a graceful shutdown while running for a few minutes on battery.
  • Like
Reactions: mrmuttley
ouch, it works but no great learning experience...
next step was removing sda2 from /etc/fstab or unit .mount files from /etc/systemd
then clear only sda2...
  • Like
Reactions: mrmuttley
Thanks for your feedback and assistance.

Landed up having to solve multiple issues so I did land up learning quite a bit!
Realised that my backsups were good and I what I should do going forward.

Once again, thanks for taking the time to reply and assist me.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!