Proxmox will not boot from ZFS (UEFI mode) - No root device specified

victorhooi

Member
Apr 3, 2018
172
11
18
33
I have a SuperMicro 1029P-WTR, and I have just installed Proxmox 6.1 on it.

The boot disk is a M.2 NVMe SSD (Team MP34).

I chose to install on ZFS (RAID0) on this disk.

I had boot mode previously set to DUAL, but I've changed it to UEFI after the install (SuperMicro won't seem to boot from ISO in UEFI mode).

Anyhow, it seems to find the UEFI boot disk, and loads from it - but then Proxmox says:

Code:
Reading all physical volumes. This may take a while...
No root device specified. Boot arguments must include a root= parameter.
Is there something special that needs to happen for ZFS boot to work on Proxmox?
 

Attachments

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,368
360
103
South Tyrol/Italy
shop.maurer-it.com
I had boot mode previously set to DUAL, but I've changed it to UEFI after the install (SuperMicro won't seem to boot from ISO in UEFI mode).
That's probably the issue, if the installer boots up in legacy mode it won't do the full systemd-efiboot installation..

You should see a message like "EFI boot mode detected, mounting efivars filesystem" if you select the debug mode of the installer on booting the ISO.

Is there something special that needs to happen for ZFS boot to work on Proxmox?
What happens if you boot now also in the "DUAL" mode?
 

victorhooi

Member
Apr 3, 2018
172
11
18
33
Aha, the issue is - if I set it to UEFI from the start - then the SuperMicro doesn't seem to boot from the ISO.

If it's in DUAL - is there some way to force the Proxmox installer to go to UEFI mode?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,368
360
103
South Tyrol/Italy
shop.maurer-it.com
Aha, the issue is - if I set it to UEFI from the start - then the SuperMicro doesn't seem to boot from the ISO.
Does it just hang? How did you attached the ISO? USB stick or virtual media through IPMI/iKVM?
 

victorhooi

Member
Apr 3, 2018
172
11
18
33
I'm connecting the ISO through a Raritan Dominion KX3 KVM - this goes via USB but I believe it exposes it as an optical drive.

When set to UEFI - it simply does not show that as a bootable option.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!