[SOLVED] Proxmox WebGUI

michaelsage

New Member
Jul 10, 2020
3
0
1
40
Hi,
I have a bit of a strange problem. I can access the webgui from two different locations, but from a 3rd I am unable to connect and get

This site can’t be reached The connection was reset.
Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_RESET

I am running iptables as a firewall on the host, but the rules look good, I have also tried with no firewall rules and get the same error. Firewalling is disabled on the host and datacentre from within proxmox. I don't really know where else to look.

I am using Proxmox Virtual Environment 6.3-3 on Debian GNU/Linux 10 (buster) and both are up to date, I rebooted the server this morning to check if something weird was happening.

Thanks!
 
Last edited:

michaelsage

New Member
Jul 10, 2020
3
0
1
40
Just done a little bit more digging. In the pveproxy access log I see a - 403 error when the IP having issues tries to connect. All the other connections are passing information correctly. I am not sure what this actual means though

Code:
87.xxx - root@pam [28/01/2021:11:22:52 +0000] "GET /api2/json/nodes/xxx/status HTTP/1.1" 200 788
87.xxx - root@pam [28/01/2021:11:22:52 +0000] "GET /api2/json/cluster/tasks HTTP/1.1" 200 990
80.xxx - root@pam [28/01/2021:11:22:52 +0000] "GET /api2/json/nodes/xxx/firewall/options HTTP/1.1" 200 86
80.xxx - root@pam [28/01/2021:11:22:52 +0000] "GET /api2/json/cluster/resources HTTP/1.1" 200 678
87.xxx - root@pam [28/01/2021:11:22:53 +0000] "GET /api2/json/nodes/xxx/config HTTP/1.1" 200 62
87.xxx - root@pam [28/01/2021:11:22:53 +0000] "GET /api2/json/cluster/acme/account HTTP/1.1" 200 11
51.xxx - - [28/01/2021:11:22:53 +0000] "-" 403 -
51.xxx - - [28/01/2021:11:22:53 +0000] "-" 403 -
51.xxx - - [28/01/2021:11:22:53 +0000] "-" 403 -
51.xxx - - [28/01/2021:11:22:53 +0000] "-" 403 -

And from syslog
Code:
Jan 28 11:25:24 xxx pveproxy[17070]: cannot parse line 'acme: ' in node config
Jan 28 11:25:34 xxx pveproxy[17174]: cannot parse line 'acme: ' in node config
Jan 28 11:25:44 xxx pveproxy[17174]: cannot parse line 'acme: ' in node config

Which suggests it might be an SSL error, but the cert is good and I forced a lets encrypt renewal this morning
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,261
1,049
164
34
Vienna
did you configure an allow or deny list in /etc/default/pveproxy ?
 
  • Like
Reactions: michaelsage

michaelsage

New Member
Jul 10, 2020
3
0
1
40
haha wow! Thank you! I don't remember doing that, but apparently I did.
Thank you sooo much!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!