[SOLVED] proxmox-ve package is too old but can't get newer version

bobzer

Well-Known Member
Nov 14, 2017
37
8
48
37
Hi,
I wanna upgrade to version 6.0 but pve5to6 give me an error telling me that i need to upgrade, problem is there is no upgrade available to me and i don't understant why.

Hope you can help me
thanks

some context :

my source.list
Code:
deb http://ftp.ca.debian.org/debian stretch main contrib

deb http://ftp.ca.debian.org/debian stretch-updates main contrib

# security updates
deb http://security.debian.org stretch/updates main contrib

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

the pveversion output :
Code:
pve-manager/5.4-13/aee6f0ec (running kernel: 4.13.13-6-pve)

the apt output :
Code:
# apt update
Get:1 http://security.debian.org stretch/updates InRelease [94.3 kB]
Get:2 http://download.proxmox.com/debian/pve stretch InRelease [3,052 B]
Get:3 http://download.proxmox.com/debian/pve stretch/pve-no-subscription amd64 Packages [322 kB]         
Get:4 http://security.debian.org stretch/updates/main amd64 Packages [502 kB]                 
Ign:5 http://ftp.ca.debian.org/debian stretch InRelease
Hit:6 http://ftp.ca.debian.org/debian stretch-updates InRelease               
Hit:7 http://ftp.ca.debian.org/debian stretch Release
Get:8 http://security.debian.org stretch/updates/main Translation-en [225 kB]
Get:9 http://security.debian.org stretch/updates/contrib amd64 Packages [1,760 B]       
Get:10 http://security.debian.org stretch/updates/contrib Translation-en [1,759 B]   
Fetched 1,151 kB in 0s (1,931 kB/s)                                                         
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  irqbalance libfile-sync-perl libintl-perl libintl-xs-perl liblockfile-simple-perl liblog-agent-perl libsnappy1v5
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

the pve5to6 output :

Code:
# pve5to6
= CHECKING VERSION INFORMATION FOR PVE PACKAGES =

Checking for package updates..
PASS: all packages uptodate

Checking proxmox-ve package version..
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/PVE/CLI/pve5to6.pm line 223.
Use of uninitialized value $maj in numeric gt (>) at /usr/share/perl5/PVE/CLI/pve5to6.pm line 227.
Use of uninitialized value $maj in numeric ge (>=) at /usr/share/perl5/PVE/CLI/pve5to6.pm line 230.
FAIL: proxmox-ve package is too old, please upgrade to >= 5.4-2!

Checking running kernel version..
WARN: unexpected running and installed kernel '4.13.13-6-pve'.

= CHECKING CLUSTER HEALTH/SETTINGS =

SKIP: standalone node.

= CHECKING HYPER-CONVERGED CEPH STATUS =

SKIP: no hyper-converged ceph setup detected!

= CHECKING CONFIGURED STORAGES =

PASS: storage 'ssd' enabled and active.
PASS: storage 'data' enabled and active.
PASS: storage 'local' enabled and active.
PASS: storage 'backup' enabled and active.

= MISCELLANEOUS CHECKS =

INFO: Checking common daemon services..
PASS: systemd unit 'pveproxy.service' is in state 'active'
PASS: systemd unit 'pvedaemon.service' is in state 'active'
PASS: systemd unit 'pvestatd.service' is in state 'active'
INFO: Checking for running guests..
WARN: 6 running guest(s) detected - consider migrating or stopping them.
INFO: Checking if the local node's hostname 'Gladys' is resolvable..
INFO: Checking if resolved IP is configured on local node..
PASS: Resolved node IP '192.10.20.100' configured and active on single interface.
INFO: Check node certificate's RSA key size
PASS: Certificate 'pve-root-ca.pem' passed Debian Busters security level for TLS connections (4096 >= 2048)
PASS: Certificate 'pve-ssl.pem' passed Debian Busters security level for TLS connections (2048 >= 2048)
INFO: Checking KVM nesting support, which breaks live migration for VMs using it..
PASS: KVM nested parameter set, but currently no VM with a 'vmx' or 'svm' flag is running.

= SUMMARY =

TOTAL:    17
PASSED:   12
SKIPPED:  2
WARNINGS: 2
FAILURES: 1

ATTENTION: Please check the output for detailed information!
Try to solve the problems one at a time and then run this checklist tool again.
 
  • Like
Reactions: pva
Maybe it can help someone, my problem was really strange
so the answer came from :
Code:
pveversion --verbose
it shown that no proxmox-ve was installed I thought that this is really really strange and not normal ...
so i installed it with a simple apt install proxmox-ve

run again the pve5to6 script and it was perfectly working :)
 
Thanks a lot for posting the answer.
It did help !
 
  • Like
Reactions: bobzer

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!